Для каждого задания написать программу на языке ПАСКАЛЬ 1?

Информатика | 10 - 11 классы

Для каждого задания написать программу на языке ПАСКАЛЬ 1.

Среди двухзначных чисел найти количество четных чисел.

2. среди двухзначных чисел найти те числа, у которых 1 цифра четная.

3. среди двухзначных чисел найти те числа, которые кратные 3 и 4.

4. среди трехзначных чисел найти, те у которых все цифры равны.

Ответить на вопрос
Ответы (1)
ДанилРазводов 24 янв. 2020 г., 16:47:11

1. program okay ; {здесь я думаю, все понятно}

var i, count : byte ; {i - будет счетчиком, в переменную count мы запишем количество четных чисел}

begin

count : = 0 ; {пока что мы не нашли ни одного четного числа}

for i : = 10 to 99 do {перебираем двузначные числа, т.

Е. от 10 до 99}

If i mod 2 = 0 then count : = count + 1 ; {если остаток от деления на 2 (mod) равен нулю, то число четное и мы к количеству найденых прибавляем единицу}

write(count) ; {выводим на экран найденое количество четных чисел}

end.

{конец программы}

2.

Program okay ; {здесь я думаю, все понятно}

var i, count : byte ; {i - будет счетчиком, в переменную count мы запишем количество чисел с четной первой цифрой}

begin

count : = 0 ; {пока что мы не нашли ни одного нужного числа}

for i : = 10 to 99 do {перебираем двузначные числа, т.

Е. от 10 до 99}

If (i div 10) mod 2 = 0 then count : = count + 1 ; {находим целую часть от деления числа на 10 (т.

Е. первую цифру) и остаток от деления ее на 2 равен нулю, то эта цифра четная}

write(count) ; {выводим на экран найденое количество искомых чисел}

end.

{конец программы}

3.

Program okay ; {здесь я думаю, все понятно}

var i : byte ; {i - будет счетчиком}

begin

for i : = 10 to 99 do {перебираем двузначные числа, т.

Е. от 10 до 99}

If (i mod 3 = 0) and (i mod 4 = 0) then write(i) ; {проверяем кратность путем нахождения остатков от деления на 3 и 4 и выводим число на экран в случае выполнения условия кратности}

end.

{конец программы}

4.

Program okay ; {здесь я думаю, все понятно}

var i : integer ; {берем тип integer, т.

К в тип байт не входят все трехзначные числа, i - будет счетчиком} *

a, b, c : byte ; {a - цифра сотен, b - десятков, c - единиц}

begin

for i : = 100 to 990 do begin {перебираем трехзначные числа, т.

Е. от 100 до 999}

a : = i div 100 ; {находим целую часть от деления числа на 100, т.

Е. цифру сотен}

b : = (i div 10) mod 10 ; {находим двузначное число являющееся целой частью данного числа на 10, а затем остаток от деления на 10, таким образом получаем число десятков}

c : = i mod 10 ; {находим остаток от деления числа на 10, т.

Е. цифру единиц}

if (a = b) and (b = c) then write(i) ; {Проверяем, выполняется ли условие равенства цифр числа и в случае выполнения, выводим данное число на экран}

end ; {закрываем цикл}

end.

{конец программы} * - тип byte может принимать значения от 0 до 255, а тип integer - от - 32767 до 32768.

Прим : все что выделено жирным, это код программы.

Все остальное - это пояснение и вставлять их в программу не нужно.

JuliJulia 6 дек. 2020 г., 07:03:38 | 10 - 11 классы

Помогите сделать?

Помогите сделать.

Среди двухзначных чисел найти те, сумма квадратов цифр которых делится на 13 .

Какртинка это пример как надо делать.

Stasevanne26 5 янв. 2020 г., 18:55:45 | 5 - 9 классы

Среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15?

Среди четырёхзначных чисел найти все числа сумма цифр, которых кратно 3 и больше 15.

ЭмИлЬ1234 19 апр. 2020 г., 01:00:14 | 10 - 11 классы

Найти сумму двухзначных четных чисел?

Найти сумму двухзначных четных чисел.

Лысыйй 16 апр. 2020 г., 23:32:43 | 5 - 9 классы

Найти сумму всех двухзначных четных натуральных чисел?

Найти сумму всех двухзначных четных натуральных чисел.

Maxat2005 3 сент. 2020 г., 21:48:20 | 10 - 11 классы

Среди двухзначных чисел найдите те, сумма квадратов цифр которых делиться на 13?

Среди двухзначных чисел найдите те, сумма квадратов цифр которых делиться на 13.

В ПАСКАЛЕ!

Пожалуйста!

Svetol8ohullk 23 нояб. 2020 г., 03:07:03 | 5 - 9 классы

Помогите умоляю, срочно нужно, ответ отмечу как лучший)Написать программу, найти среди двухзначных чисел те, которые делятся на 2 и на 11 без остатка?

Помогите умоляю, срочно нужно, ответ отмечу как лучший)Написать программу, найти среди двухзначных чисел те, которые делятся на 2 и на 11 без остатка.

Валерия123123 20 июл. 2020 г., 11:14:21 | 10 - 11 классы

С клавиатуры вводятся 3 числа?

С клавиатуры вводятся 3 числа.

Найти количество и сумму четных чисел среди них.

Если среди введенных четных нет, то вывести соответствующее сообщение.

Lenapontileeva 20 дек. 2020 г., 00:18:57 | 10 - 11 классы

Паскаль :Найти кол - во двухзначных чисел, в записи которых встречается цифра 6?

Паскаль :

Найти кол - во двухзначных чисел, в записи которых встречается цифра 6.

Nananssss 2 сент. 2020 г., 16:51:16 | 5 - 9 классы

Среди чисел от 100 до 1000 найти сумму тех чисел которые заканчиваются на цифру 4?

Среди чисел от 100 до 1000 найти сумму тех чисел которые заканчиваются на цифру 4.

Swetas1987 14 окт. 2020 г., 00:43:43 | 5 - 9 классы

Среди всех трезначных чисел найти числа для которых верно утверждение : сумма кубов цифр этого числа равна самому числу?

Среди всех трезначных чисел найти числа для которых верно утверждение : сумма кубов цифр этого числа равна самому числу.

Составить Паскаль программу.

На этой странице сайта вы найдете ответы на вопрос Для каждого задания написать программу на языке ПАСКАЛЬ 1?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.