Даю 65 баллов?

Информатика | 5 - 9 классы

Даю 65 баллов!

Паскаль, пж я не разбираюсь в этом языке, помогите пжжпж

Создать массив из 16 элементов.

Заполнить его целыми случайными числами в интервале от 1 до 11.

Найти в нем количество чётных элементов.

Отсортировать массив по убыванию.

Заменить все чётные элементы на их количество.

Вывести массив в строку с комментариями.

Ответить на вопрос
Ответы (1)
Infinitysoul911 2 мая 2024 г., 12:33:01

Ответ :

begin   ; var N : array of integer ;   ; SetLength(N, 16) ;   ; N.

FillRandom(1, 11) ;   ; var Q : = N.

FindAll(x - > ; x mod 2 = 0).

Length ;   ; writeln('Количество четных элементов : ', Q) ;   ; N.

Sort ; Reverse(N) ;   ; for var l : = N.

Low to N.

High do N[l] : = (N[l] mod 2 = 0)?

Q : N[l] ;   ; writeln('Полученный массив : ', N) ;

end.

Объяснение : var N : array of integer ; Вводим наш массив с числами   ; SetLength(N, 16) ; Устанавливаем его длину, 0 - первый элемент, 15 - последний, итого 16 ячеек   ; N.

FillRandom(1, 11) ; Заполняем массив случайным образом числами от 1 до 11   ; var Q : = N.

FindAll(x - > ; x mod 2 = 0).

Length ; Находим количество четных элементов.

X mod 2 остаток от деления каждого элемента на 2   ; {Процедура FindAll заносит все значения, по условию в отдельный массив, через .

Length смотрим его длину} writeln('Количество четных элементов : ', Q) ;   ; N.

Sort ; Reverse(N) ; N.

Sort - сортирует массив по возрастанию, а reverse() меняет последовательность на противоположную, соответственно, теперь он отсортирован по убыванию   ; for var l : = N.

Low to N.

High do N[l] : = (N[l] mod 2 = 0)?

Q : N[l] ;   ; От начала массива и до его конца, над каждым элементом смотрим - четный он или нет, если четный - заменяем на Q (число элементов)   ; writeln('Полученный массив : ', N) ;

Светкаsveta 27 янв. 2024 г., 11:12:57 | 10 - 11 классы

Язык Си заполнить массив из 10 элементов случайными числами в интервале [ - 10 ; 10] и выполнить инверсию отдельно для 1 - й и 2 - й половин массива?

Язык Си заполнить массив из 10 элементов случайными числами в интервале [ - 10 ; 10] и выполнить инверсию отдельно для 1 - й и 2 - й половин массива.

Dashulyagolubets 3 янв. 2024 г., 02:31:50 | 5 - 9 классы

В одномерном массиве все отрицательные элементы переместить в начало массива, а остальные – в конец с сохранением порядка следования?

В одномерном массиве все отрицательные элементы переместить в начало массива, а остальные – в конец с сохранением порядка следования.

Дополнительный массив заводить не разрешается.

​.

Sharkovka05 1 февр. 2024 г., 22:51:40 | студенческий

Программа на С + +Не сталкивался и с этимПросьба большая помочьСоздать целочисленный массив типа short int размером n?

Программа на С + +

Не сталкивался и с этим

Просьба большая помочь

Создать целочисленный массив типа short int размером n.

Элементы массива инициализируются по следующему алгоритму :

1) число А вводится с консоли ;

2) используя битовые операции, сделать в нем так, чтобы 11 бит был заменён значением 5 - го бита, а остальные сохранили свои значения.

3) присвоить преобразованное число А текшему элементу массива.

Инициализированный массив вывести на печать и найти в нём элементы, у которых старшая четвёрка бит имеет все единицы.

Dmitrievvanya 4 мар. 2024 г., 04:10:55 | 10 - 11 классы

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ?

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ!

Дано неотрицательное число N - количество элементов массива (N< ; = 100)

Заполнить массив из N элементов первыми натуральными трехзначными числами, произведение цифр которых есть трехзначное число.

Саша1322 25 мар. 2024 г., 22:31:52 | 10 - 11 классы

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив?

Составить программу на Паскале, которая в двумерном массиве определяет максимальный элемент в каждой строке и записывает его в одномерный массив.

Для определения максимального элемента в строке использовать function , а для ввода и вывода массивов - procedure.

Dagirovauma 8 апр. 2024 г., 20:43:38 | 5 - 9 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел

ЯЗЫК - PASCAL

35 баллов.

Анжелика268 18 февр. 2024 г., 07:10:49 | 5 - 9 классы

Дан одномерный массив B из 20 целых чисел(числа вводятся по формуле (i + 2 * (i - 1)), вывестина экран массив в строку через пробел, найти ивывести максимальный элемент массива?

Дан одномерный массив B из 20 целых чисел

(числа вводятся по формуле (i + 2 * (i - 1)), вывести

на экран массив в строку через пробел, найти и

вывести максимальный элемент массива.

Baulinakristina706 8 апр. 2024 г., 05:30:23 | 10 - 11 классы

Массив размерности N задается случайным образом ?

Массив размерности N задается случайным образом .

Вычислите элементы массива которые стоят на четнвх местах , например A[2] = .

A[4] = .

OpchikPolininPopchik 25 февр. 2024 г., 10:35:10 | 10 - 11 классы

Срочно?

Срочно!

Третья пересдача, помогите написать программу для этой задачи, пожалуйста!

Язык C + +

Задан числовой массив А[m][n].

Составить программу поиска элемента массива, который является наибольшим из минимальных по строкам​.

Annatitova12345 3 апр. 2024 г., 09:43:12 | 5 - 9 классы

Дан массив из N элементов?

Дан массив из N элементов.

Найти и вывести элементы этого массива, принадлежащие диапазону от А до В (А и В ввести с клавиатуры).

Язык программирования pascal.

F39821 16 янв. 2024 г., 00:26:34 | 5 - 9 классы

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ ?

ДАН ЦЕЛОЧИСЛЕННЫЙ МАССИВ ИЗ 30 ЭЛЕМЕНТОВ .

ЭЛЕМЕНТЫ МАССИВА МОГУТ ПРИНИМАТЬ ЗНАЧЕНИЯ ОТ - 1000 ДО 1000.

ОПИШИТЕ НА РУССКОМ ИЛИ НА 1 ИЗ ЯЗЫКОВ ПРОГРАММИРОВАНИЯ АЛГОРИТМ , КОТ ПОЗВОЛЯЕТ ПОДСЧИТАТЬ И ВЫВЕСТИ СРЕДНЕЕ АРИФМЕТИЧЕСКОЕ ТЕХ ЭЛЕМЕНТОВ МАССИВА , КОТ ПО СВОЕМУ ЗНАЧЕНИЮ МЕНЬШЕ ПОСЛЕДН ЭЛЕМЕНТА ЭТОГО МАССИВА .

ГАРАНТИРУЕТСЯ , ЧТО В ИСХОДНОМ МАССИВЕ ЕСТЬ ХОТЯ БЫ 1 ТАКОЙ ЭЛЕМЕНТ .

На этой странице вы найдете ответ на вопрос Даю 65 баллов?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.