Среди всех трезначных чисел найти числа для которых верно утверждение : сумма кубов цифр этого числа равна самому числу?

Информатика | 5 - 9 классы

Среди всех трезначных чисел найти числа для которых верно утверждение : сумма кубов цифр этого числа равна самому числу.

Составить Паскаль программу.

Ответить на вопрос
Ответы (1)
Aruzhanka7 14 окт. 2020 г., 00:43:45

1. Современный вариант / / PascalABC.

NET 3.

1, сборка 1218 от 12.

04. 2016

begin var pow3 : integer - > ; integer : = n - > ; n * n * n ; var Good : integer - > ; boolean : = n - > ; (pow3(n div 100) + pow3((n div 10) mod 10) + pow3(n mod 10)) = n ; Range(100, 999).

Where(x - > ; Good(x)).

Print

end.

Результат :

153 370 371 407

2.

Школьный вариант / / PascalABC.

NET 3.

1, сборка 1218 от 12.

04. 2016

var i, n, d100, d10, d1 : integer ;

begin for i : = 100 to 999 do begin d100 : = i div 100 ; d10 : = (i div 10) mod 10 ; d1 : = i mod 10 ; if d100 * sqr(d100) + d10 * sqr(d10) + d1 * sqr(d1) = i then Write(i, ' ') end ;

end.

Карамелька8653 25 апр. 2020 г., 02:58:21 | 10 - 11 классы

Паскаль?

Паскаль.

Найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B.

Poni111 24 янв. 2020 г., 16:47:06 | 10 - 11 классы

Для каждого задания написать программу на языке ПАСКАЛЬ 1?

Для каждого задания написать программу на языке ПАСКАЛЬ 1.

Среди двухзначных чисел найти количество четных чисел.

2. среди двухзначных чисел найти те числа, у которых 1 цифра четная.

3. среди двухзначных чисел найти те числа, которые кратные 3 и 4.

4. среди трехзначных чисел найти, те у которых все цифры равны.

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

1000Анн 21 июн. 2020 г., 08:07:58 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

Даны 2 числа.

Найти их сумму, если числа равны, и найти их произведение, если числа не равны.

Написать блок схему и составить программу на Паскаль.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Kovanov2014 27 окт. 2020 г., 02:37:24 | 10 - 11 классы

Дано трёхзначное число?

Дано трёхзначное число.

Найти среди цифр этого числа, максимальное.

Программа в Паскале.

Safolur74 7 июн. 2020 г., 11:44:24 | 5 - 9 классы

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа?

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа.

Паскаль.

Викасмешная 8 апр. 2020 г., 11:36:36 | 5 - 9 классы

Составить программу поиска первых n чисел, равных сумме кубов своих цифр?

Составить программу поиска первых n чисел, равных сумме кубов своих цифр.

Программа - Паскаль АBC.

Nrodionov2000 22 нояб. 2020 г., 21:15:29 | 5 - 9 классы

Если трёхзначное число равно сумме кубов цифр, образующихэто число, то такое число называется «магическим»?

Если трёхзначное число равно сумме кубов цифр, образующих

это число, то такое число называется «магическим».

Найти и вывести все

«магические числа».

(Написать функцию вычисления суммы кубов цифр

трёхзначного числа).

Паскаль, через функции пользователя.

Drobitko1983 23 нояб. 2020 г., 19:49:12 | 10 - 11 классы

Программа проверяющая верно ли утверждение что сумма цифр двузначного числа четное(на паскале)?

Программа проверяющая верно ли утверждение что сумма цифр двузначного числа четное(на паскале).

На этой странице сайта вы найдете ответы на вопрос Среди всех трезначных чисел найти числа для которых верно утверждение : сумма кубов цифр этого числа равна самому числу?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.