Ввести 3 - х значное число , вывести сумму его цифр ( паскаль)?

Информатика | 5 - 9 классы

Ввести 3 - х значное число , вывести сумму его цифр ( паскаль).

Ответить на вопрос
Ответы (1)
Люся17 7 февр. 2020 г., 01:25:49

Program summa_4isel ;

Uses crt ;

Var a, e, z, y, x : integer ;

Begin

Writeln('Введите трехзначное число') ;

Readln(a) ;

x : = a div 100 ;

y : = (a - x * 100) div 10 ;

z : = a - y * 10 - x * 100 ;

e : = x + y + z ;

writeln('Сумма чисел ', x, ' ', y, ' и ', z, ' равна ', e, '.

') ;

end.

В задаче переменными обозначены :

a - трехзначное число

e - сумма чисел

x, y и z - первое, второе и третье число соответственно.

P. s.

Uses crt ; можно удалить.

Но не желательно.

Ksenua96 21 июн. 2020 г., 07:08:14 | 5 - 9 классы

Через паскаль 1 ввести 3 числа, вывести наименьшее 2 ввести номер месяца , вывести название месяца 3 ввести 5 чисел, вывести в порядке убывания?

Через паскаль 1 ввести 3 числа, вывести наименьшее 2 ввести номер месяца , вывести название месяца 3 ввести 5 чисел, вывести в порядке убывания.

VlaDikKravaev 12 дек. 2020 г., 00:21:46 | 10 - 11 классы

Составить программу на языке паскаль : ввести 4 числа и вывести большее из них?

Составить программу на языке паскаль : ввести 4 числа и вывести большее из них.

( срочно).

Adelisamolkova 1 февр. 2020 г., 17:37:02 | 10 - 11 классы

В Паскале?

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Skromnyaschka 29 нояб. 2020 г., 10:56:33 | 10 - 11 классы

Ввести с клавиатуры двухзначное число?

Ввести с клавиатуры двухзначное число.

Опред.

, равна ли сумма его цифр 10.

Решить в паскале.

Kusena 17 апр. 2020 г., 05:15:06 | 10 - 11 классы

Паскаль?

Паскаль.

Вывести на экран квадрат средней цифры пятизначного числа.

Rodrigue 2 апр. 2020 г., 07:41:07 | 5 - 9 классы

Как найти произведение цифр четырех значного числа на языке паскаль?

Как найти произведение цифр четырех значного числа на языке паскаль?

Азиретбибиаида 12 июл. 2020 г., 21:12:10 | 1 - 4 классы

Ввести слово?

Ввести слово.

Если его первая буква "а", вывести его.

Паскаль срочно.

Mrolegmega 5 дек. 2020 г., 05:12:55 | 10 - 11 классы

Как делать?

Как делать?

Ввести два целых числа x y определить что больше квадрат суммы или сумма квадратов, вывести ответы "квадрат суммы" или "сумма квадратов" или "значения равны".

В паскале подробно.

Miss599 4 нояб. 2020 г., 11:30:56 | 5 - 9 классы

На языке ПаскальВвести 3 числа среди них найти наименьшее и вывести его?

На языке Паскаль

Ввести 3 числа среди них найти наименьшее и вывести его.

Solodkovan16 21 окт. 2020 г., 18:19:02 | 10 - 11 классы

Ввести трехзначное число ?

Ввести трехзначное число .

Вычислить корень квадратный второй цифры(паскаль).

На этой странице находится ответ на вопрос Ввести 3 - х значное число , вывести сумму его цифр ( паскаль)?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.