В Паскале?

Информатика | 10 - 11 классы

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Ответить на вопрос
Ответы (1)
Kudratova1984 1 февр. 2020 г., 17:37:07

1)Задача решается несколькими способами.

Можно перевести число в строку и с помощью строковых функций (и процедур) определить, есть ли в ней одинаковые символы.

Еще один способ (на мой взгляд, чуть - чуть попроще) заключается в том, чтобы просто сосчитать количество каждой цифры в числе :

Пусть у нас есть массив col[0.

9], который будет хранить количество цифр.

Сосчитать количество каждой цифры в массиве ch можно так :

while (ch mod 10)> ; 0 do begin

c : = ch mod 10 ;

ch : = ch div 10 ;

col[ c ] : = col[ c ] + 1 ;

end ;

Теперь нужно просто посмотреть, нет ли в массиве col числа > ; = 2 .

Если такое есть, то это будет означать, что цифра встретиласи два или более раза :

b : = false ;

for i : = 0 to 9 do if col[ i ]> ; = 2 then b : = true ;

if b then writeln ('да') else writeln('нет') ;

Кстати, не забудь обнулить массив col перед использованием.

2)В этой последовательности каждый следующий член равен сумме предыдущего члена и порядкового номера предыдузего члена

1

2 = 1 + 1

4 = 2 + 2

7 = 4 + 3

11 = 7 + 4

Очевидно, задача на циклы.

Цикл должен отсчитать 10 первых членов :

for i : = 1 to 10 do begin.

Внутри мы должны сосчитать сам член, записать его и вывести квадрат и куб этого члена.

I - порядковый номер члена, а сам член предположим записываем в переменную ch.

Тогда он вычисляется по формуле

ch : = ch + i - 1 ;

Не забудь перед циклом указать начальное значение ch.

KateykinaKatya 7 февр. 2020 г., 01:25:44 | 5 - 9 классы

Ввести 3 - х значное число , вывести сумму его цифр ( паскаль)?

Ввести 3 - х значное число , вывести сумму его цифр ( паскаль).

Opsdas 15 июн. 2020 г., 23:25:08 | 10 - 11 классы

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом?

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом.

Написать программу в Паскале без массивов.

Vitalikkovalchuk 19 мая 2020 г., 13:59:28 | 10 - 11 классы

Ввести целое число а и целое число n, рассчитать сумма 1 * а + 2 * а * 3 * а + ?

Ввести целое число а и целое число n, рассчитать сумма 1 * а + 2 * а * 3 * а + .

+ n * a.

Skromnyaschka 29 нояб. 2020 г., 10:56:33 | 10 - 11 классы

Ввести с клавиатуры двухзначное число?

Ввести с клавиатуры двухзначное число.

Опред.

, равна ли сумма его цифр 10.

Решить в паскале.

Alisa16 10 дек. 2020 г., 02:58:32 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Zdance 8 июн. 2020 г., 08:11:47 | 10 - 11 классы

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания?

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания.

Milana4569 25 авг. 2020 г., 21:39:45 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Но нужно сделать программу так чтобы она работала с любым числом.

Kcy81 12 июл. 2020 г., 17:04:03 | 5 - 9 классы

Ввести целое число и определить, верно ли, что все его цифры четные?

Ввести целое число и определить, верно ли, что все его цифры четные.

(Кумир).

Gosha8 2 окт. 2020 г., 01:37:03 | 10 - 11 классы

Всем привет?

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Minikotik12367 22 мая 2020 г., 18:32:33 | 5 - 9 классы

1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом?

1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

Вы находитесь на странице вопроса В Паскале? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.