С клавиатуры вводятся числа и последовательно суммируются?

Информатика | студенческий

С клавиатуры вводятся числа и последовательно суммируются.

Найти количество введенных чисел, когда их сумма превысила 100.

Ответить на вопрос
Ответы (1)
Linochka104 31 дек. 2021 г., 10:17:36

Var a, k, sum : integer ;

begin while (sum < 100) do begin readln(a) ; k : = k + 1 ; sum : = sum + a ; end ; writeln(k) ;

end.

Pahan1312 18 янв. 2021 г., 20:32:48 | 5 - 9 классы

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем?

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем.

(a = 0 признак окончания ввода , ноль не входит в последовательность).

Программа должна вывести количество и сумму всех чисел последовательности.

Alina566526 3 апр. 2021 г., 08:20:33 | 5 - 9 классы

С клавиатуры вводятся n чисел найти произведение введенных чисел?

С клавиатуры вводятся n чисел найти произведение введенных чисел!

Bogdan1143 1 июн. 2021 г., 03:13:18 | 10 - 11 классы

С клавиатуры вводятся два трехзначных числа ?

С клавиатуры вводятся два трехзначных числа .

Выяснить , образуют ли сумма цифр сотен, сумма цифр десятков , сумма цифр единиц введенных чисел убывающую последовательность.

Asabirsyanova21pony 2 апр. 2021 г., 18:09:53 | 5 - 9 классы

С клавиатуры вводится произвольная последовательность положительных чисел за которыми слудет 0?

С клавиатуры вводится произвольная последовательность положительных чисел за которыми слудет 0.

Определить максимальное число в этой последовательности, количество четных чисел.

Dimapozzik 29 мар. 2021 г., 16:21:29 | 5 - 9 классы

Вводится последовательность чисел, признак конца ввода, ввод числа 0?

Вводится последовательность чисел, признак конца ввода, ввод числа 0.

Найти сумму чисел не кратных 7.

SOS.

Igoryn2815 16 авг. 2021 г., 22:18:08 | 5 - 9 классы

Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль?

Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль.

А) Найти сумму введенных чисел.

B) Найти количество четных отрицательных чисел среди введенных.

C) Найти максимальное число среди введенных.

Jadira9618 5 авг. 2021 г., 08:13:15 | 5 - 9 классы

1. Найти количество чисел, кратных 3 и 5, в промежутке от 1 до N?

1. Найти количество чисел, кратных 3 и 5, в промежутке от 1 до N.

N вводится с клавиатуры.

2. Найти сумму цифр в числе.

Паскаль.

Алексей1999 28 янв. 2021 г., 23:21:12 | 10 - 11 классы

Найти сумму чисел введенных с клавиатуры количество чисел задать через оператор read?

Найти сумму чисел введенных с клавиатуры количество чисел задать через оператор read.

Паскаль, срочноо.

Machkill 28 мая 2021 г., 10:26:26 | 1 - 4 классы

С клавиатуры вводят 15 чисел?

С клавиатуры вводят 15 чисел.

Найти сумму всех положительных чисел.

В С + + , пожалуйста.

REZEDA99 1 июл. 2021 г., 14:27:13 | 10 - 11 классы

Написать программу на языке программирования высокого уровня С + + вычисляющую количество введенных чисел и максимальный элемент из входного потока?

Написать программу на языке программирования высокого уровня С + + вычисляющую количество введенных чисел и максимальный элемент из входного потока.

Данные ввести с клавиатуры и записать во внешний файл на диске.

Количество введенных чисел не ограничено.

Признак окончания ввода чисел во входном потоке - число 421.

После записи введенных данных в конец файла дописать количество введенных чисел и максимальное введенное число.

Например, Количество введенных чисел - 12, максимальное среди введенных - 345, причем признак окончания ввода - последнее число 421 не учитывать.

Вы открыли страницу вопроса С клавиатуры вводятся числа и последовательно суммируются?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся студенческий. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.