Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль?

Информатика | 5 - 9 классы

Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль.

А) Найти сумму введенных чисел.

B) Найти количество четных отрицательных чисел среди введенных.

C) Найти максимальное число среди введенных.

Ответить на вопрос
Ответы (1)
Xudaykulov00 16 авг. 2021 г., 22:18:11

/ / PascalABC.

Net 3.

2

begin

var max : = - 1000000000 ;

var sum : = 0 ; var count : = 0 ; var a : = 0 ;

repeat

a : = readinteger('Введите число : ') ;

if (a.

IsEven) and (amax then max : = a ;

sum + = a ;

until a = 0 ;

writeln ('a) ', sum) ;

writeln ('b) ', count) ;

write ('c) ', max) ;

end.

Smelevazhena 17 апр. 2021 г., 02:29:55 | 5 - 9 классы

Найти сумму чисел больших 7 среди 10 введенных с клавиатуры?

Найти сумму чисел больших 7 среди 10 введенных с клавиатуры.

Alina566526 3 апр. 2021 г., 08:20:33 | 5 - 9 классы

С клавиатуры вводятся n чисел найти произведение введенных чисел?

С клавиатуры вводятся n чисел найти произведение введенных чисел!

0992448003 12 мая 2021 г., 04:54:40 | 5 - 9 классы

Составить программу?

Составить программу!

На языке Паскаль

Подсчитать количество отрицательных чисел из 10 введенных с клавиатуры.

Найти количество чисел, не больше 100.

Olgasviribova 24 авг. 2021 г., 20:57:27 | 5 - 9 классы

Среди 10 чисел, введенных с клавиатуры, найти сумму тех, которые кратны 2?

Среди 10 чисел, введенных с клавиатуры, найти сумму тех, которые кратны 2.

Программа в паскале).

Али122004 8 июн. 2021 г., 00:18:05 | 5 - 9 классы

Напишите программу, которая для последовательности целых чисел определяет количество четных чисел?

Напишите программу, которая для последовательности целых чисел определяет количество четных чисел.

Программа получает на вход количество чисел в последоввтельности, а затем сами числа.

Количество чисел не привышает 1000.

Введенные числа не привышвют 10000 и не меньше - 10000.

Программа должна вывести одно число - количество всех четных чисел в последоввтельности.

Если среди введенных чисел нет четных, то результат равен 0.

Алексей1999 28 янв. 2021 г., 23:21:12 | 10 - 11 классы

Найти сумму чисел введенных с клавиатуры количество чисел задать через оператор read?

Найти сумму чисел введенных с клавиатуры количество чисел задать через оператор read.

Паскаль, срочноо.

АртемКириченко 24 апр. 2021 г., 10:30:44 | 5 - 9 классы

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0?

Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0.

В конце работы программы на экран выводится сумма и произведение введенных чисел.

REZEDA99 1 июл. 2021 г., 14:27:13 | 10 - 11 классы

Написать программу на языке программирования высокого уровня С + + вычисляющую количество введенных чисел и максимальный элемент из входного потока?

Написать программу на языке программирования высокого уровня С + + вычисляющую количество введенных чисел и максимальный элемент из входного потока.

Данные ввести с клавиатуры и записать во внешний файл на диске.

Количество введенных чисел не ограничено.

Признак окончания ввода чисел во входном потоке - число 421.

После записи введенных данных в конец файла дописать количество введенных чисел и максимальное введенное число.

Например, Количество введенных чисел - 12, максимальное среди введенных - 345, причем признак окончания ввода - последнее число 421 не учитывать.

Sowa20 31 дек. 2021 г., 10:17:32 | студенческий

С клавиатуры вводятся числа и последовательно суммируются?

С клавиатуры вводятся числа и последовательно суммируются.

Найти количество введенных чисел, когда их сумма превысила 100.

Cholhonaiaitba 22 сент. 2021 г., 16:19:30 | 10 - 11 классы

Напишите пожалуйста программу на языке СИ?

Напишите пожалуйста программу на языке СИ.

Придумайте алгоритм вводящий три целых числа, определяющих количество максимальных чисел среди введенных.

Перед вами страница с вопросом Написать программу решения задачи : Вводить целые числа с клавиатуры, пока не будет введен ноль?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.