Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем?

Информатика | 5 - 9 классы

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем.

(a = 0 признак окончания ввода , ноль не входит в последовательность).

Программа должна вывести количество и сумму всех чисел последовательности.

Ответить на вопрос
Ответы (1)
МАсёНаК 18 янв. 2021 г., 20:32:51

Var a, b, c : integer ;

begin

b : = 0 ;

c : = 0 ;

readln(a) ;

while a < ; > ; 0 do

begin

b : = b + 1 ;

c : = c + a ;

readln(a) ;

end ;

writeln('Кол - во : ', b) ;

writeln('Сумма : ', c) ;

end.

Svetlana516298 23 янв. 2021 г., 04:11:51 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

Aiana2006 21 янв. 2021 г., 01:42:09 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество однозначных чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет количество однозначных чисел, кратных 3.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : количество однозначных чисел, кратных 3.

Creeper82 25 февр. 2021 г., 07:58:12 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

ОЧЕНЬ СРОЧНО.

DariyaP 2 авг. 2021 г., 14:44:31 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается число 0(0 - признак окончания ввода, не входит в последовательность

СРОЧНО, ПОЖАЛУЙСТА, НА ПАСКАЛЕ.

PokemonYouTube 18 авг. 2021 г., 16:12:33 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел?

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

Марина847 15 июн. 2021 г., 12:40:14 | 5 - 9 классы

17. Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3?

17. Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : сумму всех однозначных чисел, кратных 3.

Kirillmashakirill 7 сент. 2021 г., 01:12:46 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается 0 (0 - признак окончания ввода, не входит в последовательность).

Kirill221102 24 дек. 2021 г., 17:04:58 | 10 - 11 классы

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3?

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3.

Программа получает на вход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Программа должна вывести одно число : количество четных чисел, кратных 3.

DamirMU 26 июн. 2021 г., 13:09:52 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных6 и оканчивающихся на6?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных6 и оканчивающихся на6.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает100.

Введённые числ.

MrDrosh111 29 авг. 2021 г., 19:10:11 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1?

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1.

Программа получает вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0(0 - признак окончания ввода не входит в последовательность).

Программа должна вывести одно число : сумму всех чисел кратных 7 и оканчивающихся на 1.

На странице вопроса Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.