С клавиатуры вводятся два трехзначных числа ?

Информатика | 10 - 11 классы

С клавиатуры вводятся два трехзначных числа .

Выяснить , образуют ли сумма цифр сотен, сумма цифр десятков , сумма цифр единиц введенных чисел убывающую последовательность.

Ответить на вопрос
Ответы (1)
Verakim2004 1 июн. 2021 г., 03:13:19

Var a, b, s1, s2, s3 : integer ;

begin

readln(a, b) ;

s1 : = a div 100 + b div 100 ;

s2 : = (a div 10 mod 10) + (b div 10 mod 10) ;

s3 : = a mod 10 + b mod 10 ;

writeln('s1 = ', s1, ' s2 = ', s2, ' s3 = ', s3) ;

if (s1> ; s2) and (s2> ; s3)

then writeln('Последовательность убывающая')

else writeln('Последовательность неубывающая') ;

end.

Пример :

972 761

s1 = 16 s2 = 13 s3 = 3

Последовательность убывающая.

Наташа384 24 янв. 2021 г., 10:44:40 | 10 - 11 классы

Написать функцию для нахождения суммы цифр целого числа Используя эту функцию, вывести на экран : 1)трехзначные нечетные числа, суммы цифр которых кратна 8 ; 2)те из n введенных с клавиатуры целых чис?

Написать функцию для нахождения суммы цифр целого числа Используя эту функцию, вывести на экран : 1)трехзначные нечетные числа, суммы цифр которых кратна 8 ; 2)те из n введенных с клавиатуры целых чисел, сумма цифр которых больше десяти.

Мафия2002r 23 мар. 2021 г., 19:10:06 | 5 - 9 классы

Составьте программу вычисления суммы цифр введенного с клавиатуры четырёхзначного натурального числа на паскаль?

Составьте программу вычисления суммы цифр введенного с клавиатуры четырёхзначного натурального числа на паскаль.

RuslanaBahilova 6 янв. 2021 г., 11:42:50 | 5 - 9 классы

С клавиатуры вводится натуральное число z?

С клавиатуры вводится натуральное число z.

Вычислить : количество цифр в числе z ; сумму цифр числа z ; первую и последнюю цифры числа z.

Eugene98 19 июл. 2021 г., 23:24:48 | 10 - 11 классы

С клавиатуры вводится трехзначное число?

С клавиатуры вводится трехзначное число.

Составить программу которая найдет разность цифр этого числа, стоящих в позиции единиц и сотен.

Sofi900 28 мая 2021 г., 15:15:45 | 5 - 9 классы

2) Вводится четырехзначное число с клавиатуры?

2) Вводится четырехзначное число с клавиатуры.

Определить цифру тысяч, сотен, десятков и единиц.

В окне вывода должно быть так (это пример)

Введи четырехзначное число :

1234

цифра тысяч - 1

цифра сотен - 2

цифра десятков - 3

цифра единиц - 4.

Waterpas76 8 июл. 2021 г., 12:17:20 | 5 - 9 классы

Вывести на экран все трехзначные натуральные числа, сумма цифр которых не превосходит заданное пользователем (введенное с клавиатуры) число?

Вывести на экран все трехзначные натуральные числа, сумма цифр которых не превосходит заданное пользователем (введенное с клавиатуры) число.

PascalABC

функцией или процедурой.

Papap2 18 мар. 2021 г., 05:02:00 | 5 - 9 классы

Дано натуральное трехзначное число a?

Дано натуральное трехзначное число a.

Сформировать число b, такое что : число сотен в нем равнялось бы сумме цифр числа единиц и десятков числа а, десятков в b равно увеличенному на 2 числу десятков в числе а, а вместо единиц поставить цифру 0.

С + +.

Sowa20 31 дек. 2021 г., 10:17:32 | студенческий

С клавиатуры вводятся числа и последовательно суммируются?

С клавиатуры вводятся числа и последовательно суммируются.

Найти количество введенных чисел, когда их сумма превысила 100.

Sobirovamariya 3 июл. 2021 г., 03:51:19 | 5 - 9 классы

С клавиатуры вводится четырехзначное число найдите сумму цифр в этом числе кратных трем?

С клавиатуры вводится четырехзначное число найдите сумму цифр в этом числе кратных трем.

Valtieva203 19 июл. 2021 г., 14:04:55 | 5 - 9 классы

Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом?

Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода : 567.

Пример вывода : сумма цифр числа 567 - четное число

хелп, срочно!

;

На этой странице сайта, в категории Информатика размещен ответ на вопрос С клавиатуры вводятся два трехзначных числа ?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.