Найдите потерянное число?

Информатика | 10 - 11 классы

Найдите потерянное число.

Вам даны все целые число от 1 до N + 1, кроме одного.

Найдите отсутствующее число.

Формат входных данных : в первой строке входных данных записано целое число N (1< ; = N< ; = 100, 000).

Во второй строке через пробел даны N целых чисел в диапазоне от 1 до N + 1.

Ответить на вопрос
Ответы (1)
Optimizer 22 сент. 2020 г., 11:37:38

/ / PascalABC.

Net 3.

1. 0.

1200

var f : TextFile ;

begin if not FileExists('input.

Txt') then Exit ; Reset(f, 'input.

Txt') ; var n : = ReadlnInteger(f) ; var a : = ArrFill(n + 1, 0) ; for var i : = 1 to n do a[i - 1] : = ReadInteger(f) ; a[n] : = n + 2 ; println(a) ; a.

Sort ; println(a) ; for var i : = 1 to n + 1 do if a[i - 1] < ; > ; i then begin writeln(i) ; break ; end ;

end.

Лиина97 4 июн. 2020 г., 15:25:51 | 10 - 11 классы

Задается целое число N?

Задается целое число N.

Нужно вывести количество четных делителей числа N.

Формат входных данных Единственная строка входного файла содержит единственное целое число N(1< ; = N< ; = 1000) Формат выходных данных выведите ответ к задаче.

Oskoklkovaalyona 18 мар. 2020 г., 11:21:10 | 5 - 9 классы

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N?

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N.

Входные данные Первая строка содержит целое число N (1 < ; = N < ; = 100).

Выходные данные Выведите одно целое число — сумму чисел от 1 до N.

Алия55 1 июн. 2020 г., 22:53:45 | 10 - 11 классы

Задача D Три числа Дан массив из N целых чисел а1, а2, ?

Задача D Три числа Дан массив из N целых чисел а1, а2, .

, an.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).

Во второй строке находятся N целых чисел a1, a2, .

, aN ( - 1000 ≤ ai ≤ 1000) — элементы массива.

Формат выходных данных В единственной строке выходного файла выведите одно слово «YES», если в этом массиве есть три числа сумма которых равна нулю.

Иначе, выведите «NO».

C + + надо решать!

Jshakhrai 2 июн. 2020 г., 00:47:06 | 5 - 9 классы

Напишите программу на языке СИ Напишите программу, которая вводит два целых числа, a и b ( a < ; b ), и выводит через пробел 5 случайных целых чисел на отрезке [ a , b ] ?

Напишите программу на языке СИ Напишите программу, которая вводит два целых числа, a и b ( a < ; b ), и выводит через пробел 5 случайных целых чисел на отрезке [ a , b ] .

Входные данные Входная строка содержит два целых числа a и b , разделённых пробелом.

Гарантируется, что a < ; b .

Выходные данные Нужно вывести в одной строке через пробел 5 случайных целых чисел на отрезке [ a , b ] .

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

Цунаде 25 дек. 2020 г., 17:36:17 | 5 - 9 классы

Задача C?

Задача C.

Делители Дано целое число N.

Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < ; = N < ; = 10 ^ 12) Формат выходных данных Выведите ответ к задаче.

Kisaa00101 10 нояб. 2020 г., 04:12:57 | 5 - 9 классы

Даны два целых числа от 1 до 1 000 000 000?

Даны два целых числа от 1 до 1 000 000 000.

Найти сумму этих чисел.

Входные данные : два целых числа.

Выходные данные : целое число.

На Паскале.

Вы находитесь на странице вопроса Найдите потерянное число? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.