Дан массив a из n целых чисел?

Информатика | 5 - 9 классы

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Ответить на вопрос
Ответы (1)
Ксюшка2лавки 21 мар. 2020 г., 22:38:51

Var i, n : integer ; a : array[1.

1000]of integer ;

begin

readln(n) ; for i : = 1 to n do read(a[i]) ; writeln ; for i : = 1 to n do if (i mod 2 = 0) then write(a[i], ' ') ; for i : = 1 to n do if (i mod 2 < ; > ; 0) then write(a[i], ' ') ;

end.

Badertdinovrus 8 февр. 2020 г., 04:07:52 | 5 - 9 классы

Вводится массив, состоящий из целых чисел?

Вводится массив, состоящий из целых чисел.

Найти наибольшее среди них.

Входные данные Сначала задано число N — количество элементов в массиве (1N35).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести значение наибольшего элемента в массиве.

Примеры Входные данные 3 1 2 3 Выходные данные 3.

EonEGuy1 21 нояб. 2020 г., 08:01:29 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Нумерация элементов начинается с 0.

Выведите все элементы массива с четными номерами.

Формат входных данныхСначала задано число N - количество элементов в массиве, N100.

Далее через пробел записаны N чисел - элементы массива.

Все числа по модулю не превосходят 10000

Формат выходных данныхВыведите все элементы массива с четными индексами (то есть A[0], A[2], A[4], .

).

Batkova98 30 авг. 2020 г., 10:08:47 | 5 - 9 классы

Помогите с решением, пожалуйста?

Помогите с решением, пожалуйста!

Требуется отсортировать массив по неубыванию методом "пузырька".

Входные данные В первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива.

Во второй строке задаются N чисел – элементы массива (целые числа, не превосходящие по модулю 1000).

Выходные данные Вывести получившийся массив.

STS2012 1 авг. 2020 г., 06:47:43 | 10 - 11 классы

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет максимальный среди чётных положительных элементов этого массива?

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет максимальный среди чётных положительных элементов этого массива.

Входные данные Входная строка содержит три числа : границы диапазона случайных чисел A и B , а также размер массива N .

Все числа разделены пробелами.

Гарантируется, что 0 < ; N ≤ 10000 .

Выходные данные В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – максимальный из чётных положительных элементов этого массива.

Если в массиве нет таких элементов, программа должна вывести число - 1.

B Паскале.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Nasta180392 5 июл. 2020 г., 11:15:48 | 5 - 9 классы

Pascal ABC Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз?

Pascal ABC Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз.

Входные данные Первая строка содержит размер массива N .

Во второй строке через пробел задаются N чисел – элементы массива.

Гарантируется, что 0 < ; N ≤ 10000 .

В третьей строке записано натуральное число K .

Выходные данные Программа должна вывести все элементы массива, которые встречаются ровно K раз, в порядке возрастания, разделив их пробелами.

Если таких элементов нет, программа должна вывести число 0.

Примеры входные данные 6 1 2 1 2 1 3 2 выходные данные 2.

Vypusknik2014 6 сент. 2020 г., 15:51:57 | 5 - 9 классы

Дан массив из n элементов?

Дан массив из n элементов.

Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k ?

Если есть, то вывести индексы первой такой пары чисел.

Индексация элементов начинаются с единицы Формат входных данных С клавиатуры вводится натуральное число n (n≤100).

На следующей строке через пробел вводятся n элементов массива.

Все числа по модулю не превосходят 100.

В последней строке вводится число k, (−200≤k≤200).

Формат выходных данных В качестве ответа выведите индексы искомых элементов через пробел в порядке возрастания.

Если таких элементов нет, то вывести 0.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

VADIMIII18 8 мая 2020 г., 18:54:38 | 5 - 9 классы

Паскаль?

Паскаль.

Известно, что первые два элемента массива равны a и b.

А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы).

Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.

Формат входных данных Целые положительное число n (2 Целые числа a, b ( - 50 < ; a, b < ; 50) Формат выходных данных Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел.

На этой странице сайта размещен вопрос Дан массив a из n целых чисел? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.