Дан массив a из n целых чисел?

Информатика | 5 - 9 классы

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

Ответить на вопрос
Ответы (2)
Маша241278 22 янв. 2020 г., 19:04:04

/ / Dev - C + + 5.

11 (C)

#include < ; stdio.

H> ;

int main(void)

{int arr[100], n, pos, neg ;

scanf("%d", & ; n) ;

pos = 0 ;

neg = 0 ;

for(int i = 0 ; i< ; n ; i + + ) {scanf("%d", & ; arr[i]) ; if(arr[i]> ; 0) pos + + ; if(arr[i]< ; 0) neg + + ; }

printf("%d %d", pos, neg) ;

return 0 ; }.

RIM09 22 янв. 2020 г., 19:04:09

Var i, c, k, n : integer ; ar : array[1.

10000]of integer ;

begin c : = 0 ; k : = 0 ; readln(n) ; for i : = 1 to n do begin read(ar[i]) ; if (ar[i] > ; 0) then c : = c + 1 ; if (ar[i] < ; 0) then k : = k + 1 ; end ; write(c, ' ', k) ;

end.

Olya06 20 нояб. 2020 г., 13:41:50 | 5 - 9 классы

Помогите написать программу на С + + ?

Помогите написать программу на С + + .

Дан массив, состоящий из целых чисел.

Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего).

Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные Сначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры входные данные 5 1 1 1 1 1 выходные данные 1.

Darveen 19 янв. 2020 г., 21:00:01 | 5 - 9 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего).

Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные Сначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры Входные данные 5 1 1 1 1 1 Выходные данные 1.

Badertdinovrus 8 февр. 2020 г., 04:07:52 | 5 - 9 классы

Вводится массив, состоящий из целых чисел?

Вводится массив, состоящий из целых чисел.

Найти наибольшее среди них.

Входные данные Сначала задано число N — количество элементов в массиве (1N35).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести значение наибольшего элемента в массиве.

Примеры Входные данные 3 1 2 3 Выходные данные 3.

EonEGuy1 21 нояб. 2020 г., 08:01:29 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Нумерация элементов начинается с 0.

Выведите все элементы массива с четными номерами.

Формат входных данныхСначала задано число N - количество элементов в массиве, N100.

Далее через пробел записаны N чисел - элементы массива.

Все числа по модулю не превосходят 10000

Формат выходных данныхВыведите все элементы массива с четными индексами (то есть A[0], A[2], A[4], .

).

STS2012 1 авг. 2020 г., 06:47:43 | 10 - 11 классы

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет максимальный среди чётных положительных элементов этого массива?

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет максимальный среди чётных положительных элементов этого массива.

Входные данные Входная строка содержит три числа : границы диапазона случайных чисел A и B , а также размер массива N .

Все числа разделены пробелами.

Гарантируется, что 0 < ; N ≤ 10000 .

Выходные данные В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – максимальный из чётных положительных элементов этого массива.

Если в массиве нет таких элементов, программа должна вывести число - 1.

B Паскале.

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

VADIMIII18 8 мая 2020 г., 18:54:38 | 5 - 9 классы

Паскаль?

Паскаль.

Известно, что первые два элемента массива равны a и b.

А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы).

Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.

Формат входных данных Целые положительное число n (2 Целые числа a, b ( - 50 < ; a, b < ; 50) Формат выходных данных Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел.

На этой странице находится вопрос Дан массив a из n целых чисел?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.