Дан массив a из n целых чисел?

Информатика | 5 - 9 классы

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Ответить на вопрос
Ответы (1)
27654321 3 мар. 2020 г., 00:05:20

Var i, n : integer ; a : array[1.

1000]of integer ;

begin readln(n) ; for i : = 1 to n do read(a[i]) ; writeln ; for i : = 1 to n do if (a[i] > ; = 0) then write(a[i], ' ') ;

end.

Лиина97 4 июн. 2020 г., 15:25:51 | 10 - 11 классы

Задается целое число N?

Задается целое число N.

Нужно вывести количество четных делителей числа N.

Формат входных данных Единственная строка входного файла содержит единственное целое число N(1< ; = N< ; = 1000) Формат выходных данных выведите ответ к задаче.

Алия55 1 июн. 2020 г., 22:53:45 | 10 - 11 классы

Задача D Три числа Дан массив из N целых чисел а1, а2, ?

Задача D Три числа Дан массив из N целых чисел а1, а2, .

, an.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).

Во второй строке находятся N целых чисел a1, a2, .

, aN ( - 1000 ≤ ai ≤ 1000) — элементы массива.

Формат выходных данных В единственной строке выходного файла выведите одно слово «YES», если в этом массиве есть три числа сумма которых равна нулю.

Иначе, выведите «NO».

C + + надо решать!

Badertdinovrus 8 февр. 2020 г., 04:07:52 | 5 - 9 классы

Вводится массив, состоящий из целых чисел?

Вводится массив, состоящий из целых чисел.

Найти наибольшее среди них.

Входные данные Сначала задано число N — количество элементов в массиве (1N35).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести значение наибольшего элемента в массиве.

Примеры Входные данные 3 1 2 3 Выходные данные 3.

Batkova98 30 авг. 2020 г., 10:08:47 | 5 - 9 классы

Помогите с решением, пожалуйста?

Помогите с решением, пожалуйста!

Требуется отсортировать массив по неубыванию методом "пузырька".

Входные данные В первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива.

Во второй строке задаются N чисел – элементы массива (целые числа, не превосходящие по модулю 1000).

Выходные данные Вывести получившийся массив.

STS2012 1 авг. 2020 г., 06:47:43 | 10 - 11 классы

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет максимальный среди чётных положительных элементов этого массива?

Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет максимальный среди чётных положительных элементов этого массива.

Входные данные Входная строка содержит три числа : границы диапазона случайных чисел A и B , а также размер массива N .

Все числа разделены пробелами.

Гарантируется, что 0 < ; N ≤ 10000 .

Выходные данные В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – максимальный из чётных положительных элементов этого массива.

Если в массиве нет таких элементов, программа должна вывести число - 1.

B Паскале.

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Vypusknik2014 6 сент. 2020 г., 15:51:57 | 5 - 9 классы

Дан массив из n элементов?

Дан массив из n элементов.

Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k ?

Если есть, то вывести индексы первой такой пары чисел.

Индексация элементов начинаются с единицы Формат входных данных С клавиатуры вводится натуральное число n (n≤100).

На следующей строке через пробел вводятся n элементов массива.

Все числа по модулю не превосходят 100.

В последней строке вводится число k, (−200≤k≤200).

Формат выходных данных В качестве ответа выведите индексы искомых элементов через пробел в порядке возрастания.

Если таких элементов нет, то вывести 0.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

Дмитрий394 22 сент. 2020 г., 11:37:36 | 10 - 11 классы

Найдите потерянное число?

Найдите потерянное число.

Вам даны все целые число от 1 до N + 1, кроме одного.

Найдите отсутствующее число.

Формат входных данных : в первой строке входных данных записано целое число N (1< ; = N< ; = 100, 000).

Во второй строке через пробел даны N целых чисел в диапазоне от 1 до N + 1.

Если вам необходимо получить ответ на вопрос Дан массив a из n целых чисел?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.