Задача C?

Информатика | 5 - 9 классы

Задача C.

Делители Дано целое число N.

Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < ; = N < ; = 10 ^ 12) Формат выходных данных Выведите ответ к задаче.

Ответить на вопрос
Ответы (1)
Lila16 25 дек. 2020 г., 17:36:18

Var

n, i : integer ;

begin

readln(n) ;

for i : = 1 to n do

if n mod i = 0 then

write(i, ' ') ;

readln ;

end.

Лиина97 4 июн. 2020 г., 15:25:51 | 10 - 11 классы

Задается целое число N?

Задается целое число N.

Нужно вывести количество четных делителей числа N.

Формат входных данных Единственная строка входного файла содержит единственное целое число N(1< ; = N< ; = 1000) Формат выходных данных выведите ответ к задаче.

Borodyha123 28 дек. 2020 г., 21:12:44 | 10 - 11 классы

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу ?

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .

Формат входных данных

Входной файл содержит числа , ().

Формат выходных данных

Выведите искомые делители.

Примеры :

Вход6 3

Выход3 6.

PFK 25 авг. 2020 г., 16:21:55 | 5 - 9 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Формат входных данных Задано единственное число N.

Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Atey94033 9 апр. 2020 г., 22:40:15 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Формат выходных данных Выведите ответ к задаче.

Алия55 1 июн. 2020 г., 22:53:45 | 10 - 11 классы

Задача D Три числа Дан массив из N целых чисел а1, а2, ?

Задача D Три числа Дан массив из N целых чисел а1, а2, .

, an.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).

Во второй строке находятся N целых чисел a1, a2, .

, aN ( - 1000 ≤ ai ≤ 1000) — элементы массива.

Формат выходных данных В единственной строке выходного файла выведите одно слово «YES», если в этом массиве есть три числа сумма которых равна нулю.

Иначе, выведите «NO».

C + + надо решать!

Мулла 16 июн. 2020 г., 08:22:26 | 5 - 9 классы

Дан массив из N целых чисел a1, a2?

Дан массив из N целых чисел a1, a2.

, aN.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1< ; = n< ; = 200).

Во второй строке находятся n целых чисел a1, a2.

AN ( - 1000< ; = ai< ; = 1000) - елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES", если в этом массиве есть три числа сумма которых равна нулю.

Иначе выведите "NO".

Misha13Misha13 11 июн. 2020 г., 14:04:04 | 5 - 9 классы

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд?

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Входные данные Вводится целое число n.

Выходные данные Выведите ответ на задачу, соблюдая требуемый формат.

Примеры Входные данные 3602 Выходные данные 1 : 00 : 02 Входные данные 129700 Выходные данные 12 : 01 : 40.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

Нассссссстттттяяяя 18 окт. 2020 г., 00:26:05 | 10 - 11 классы

Вам даны две строки s и t, определите длину наибольшей строки, которая встречается в обеих?

Вам даны две строки s и t, определите длину наибольшей строки, которая встречается в обеих.

Формат входных данных Первая строка входных данных содержит строку s, вторая строка содержит строку t.

Обе строки состоят только из строчных латинских букв.

1 < ; = длина строк < ; = 1, 000.

Формат выходных данных Выведите ответ к задаче.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Задача C?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.