Задача D Три числа Дан массив из N целых чисел а1, а2, ?

Информатика | 10 - 11 классы

Задача D Три числа Дан массив из N целых чисел а1, а2, .

, an.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).

Во второй строке находятся N целых чисел a1, a2, .

, aN ( - 1000 ≤ ai ≤ 1000) — элементы массива.

Формат выходных данных В единственной строке выходного файла выведите одно слово «YES», если в этом массиве есть три числа сумма которых равна нулю.

Иначе, выведите «NO».

C + + надо решать!

Ответить на вопрос
Ответы (1)
1312200780 1 июн. 2020 г., 22:53:46

Program esep ;

var i, j, k, n, sum : integer ;

input, output : text ;

a : array[1.

100] ofinteger ;

flag : boolean ;

beginflag : = false ;

Assign(Input, 'd.

In') ;

reset(input) ;

readln(input, n) ;

assign(output, 'd.

Out') ;

rewrite(output) ;

writeln('Input elements') ;

readln (n) ;

for i : = 1 to n doread(a[i]) ;

for i : = 1 to n do

for j : = 1 to n do

for k : = 1 to n do

if (i< ; > ; j) and (j< ; > ; k) and (i< ; > ; k) then

if a[i] + a[j] + a[k] = 0

then

begin

writeln(output, 'Yes') ;

flag : = true ;

halt ;

end ;

if flag = false thenwriteln(output, 'No') ;

close(input) ;

close(output) ;

end.

Макс451564 3 янв. 2020 г., 16:14:15 | 10 - 11 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Лиина97 4 июн. 2020 г., 15:25:51 | 10 - 11 классы

Задается целое число N?

Задается целое число N.

Нужно вывести количество четных делителей числа N.

Формат входных данных Единственная строка входного файла содержит единственное целое число N(1< ; = N< ; = 1000) Формат выходных данных выведите ответ к задаче.

Oskoklkovaalyona 18 мар. 2020 г., 11:21:10 | 5 - 9 классы

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N?

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N.

Входные данные Первая строка содержит целое число N (1 < ; = N < ; = 100).

Выходные данные Выведите одно целое число — сумму чисел от 1 до N.

Atey94033 9 апр. 2020 г., 22:40:15 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Формат выходных данных Выведите ответ к задаче.

Мулла 16 июн. 2020 г., 08:22:26 | 5 - 9 классы

Дан массив из N целых чисел a1, a2?

Дан массив из N целых чисел a1, a2.

, aN.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1< ; = n< ; = 200).

Во второй строке находятся n целых чисел a1, a2.

AN ( - 1000< ; = ai< ; = 1000) - елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES", если в этом массиве есть три числа сумма которых равна нулю.

Иначе выведите "NO".

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

Цунаде 25 дек. 2020 г., 17:36:17 | 5 - 9 классы

Задача C?

Задача C.

Делители Дано целое число N.

Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < ; = N < ; = 10 ^ 12) Формат выходных данных Выведите ответ к задаче.

На этой странице вы найдете ответ на вопрос Задача D Три числа Дан массив из N целых чисел а1, а2, ?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.