Задается целое число N?

Информатика | 10 - 11 классы

Задается целое число N.

Нужно вывести количество четных делителей числа N.

Формат входных данных Единственная строка входного файла содержит единственное целое число N(1< ; = N< ; = 1000) Формат выходных данных выведите ответ к задаче.

Ответить на вопрос
Ответы (1)
VAMX03 4 июн. 2020 г., 15:25:55

Var i, n, k : integer ;

begin read(n) ; for i : = 1 to n do if (i mod 2 = 0) and (n mod i = 0) then k : = k + 1 ; writeln(k) ;

end.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Borodyha123 28 дек. 2020 г., 21:12:44 | 10 - 11 классы

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу ?

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .

Формат входных данных

Входной файл содержит числа , ().

Формат выходных данных

Выведите искомые делители.

Примеры :

Вход6 3

Выход3 6.

PFK 25 авг. 2020 г., 16:21:55 | 5 - 9 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Формат входных данных Задано единственное число N.

Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Atey94033 9 апр. 2020 г., 22:40:15 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Формат выходных данных Выведите ответ к задаче.

Алия55 1 июн. 2020 г., 22:53:45 | 10 - 11 классы

Задача D Три числа Дан массив из N целых чисел а1, а2, ?

Задача D Три числа Дан массив из N целых чисел а1, а2, .

, an.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю.

Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).

Во второй строке находятся N целых чисел a1, a2, .

, aN ( - 1000 ≤ ai ≤ 1000) — элементы массива.

Формат выходных данных В единственной строке выходного файла выведите одно слово «YES», если в этом массиве есть три числа сумма которых равна нулю.

Иначе, выведите «NO».

C + + надо решать!

Мулла 16 июн. 2020 г., 08:22:26 | 5 - 9 классы

Дан массив из N целых чисел a1, a2?

Дан массив из N целых чисел a1, a2.

, aN.

Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1< ; = n< ; = 200).

Во второй строке находятся n целых чисел a1, a2.

AN ( - 1000< ; = ai< ; = 1000) - елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES", если в этом массиве есть три числа сумма которых равна нулю.

Иначе выведите "NO".

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Цунаде 25 дек. 2020 г., 17:36:17 | 5 - 9 классы

Задача C?

Задача C.

Делители Дано целое число N.

Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < ; = N < ; = 10 ^ 12) Формат выходных данных Выведите ответ к задаче.

Вопрос Задается целое число N?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.