Вычислить сумму первых N чисел натурального ряда?

Информатика | 10 - 11 классы

Вычислить сумму первых N чисел натурального ряда.

С использованием операторов цикла For - To (или For - Downto), While - Do и Repeat - Until.

Паскаль.

Ответить на вопрос
Ответы (1)
Vreditel 10 нояб. 2020 г., 21:02:15

Const

c = 10 ;

var a : array[1.

C] of integer ;

n, i, s : integer ;

begin

writeln('Введите элементы массива') ;

for i : = 1 to c do

read(a[i]) ;

writeln('Введите количество первых N чисел') ;

read(n) ;

for i : = 1 to n do

s : = s + a[i] ;

writeln('Сумма первых ', n, ' чисел массива = ', s) ;

end.

Сидоров 3 окт. 2020 г., 05:43:18 | 5 - 9 классы

Найдите среднее арифметическое 5 любых чисел?

Найдите среднее арифметическое 5 любых чисел.

В паскале с оператором цикла for.

DONikita 4 окт. 2020 г., 17:29:13 | 10 - 11 классы

Программирование на паскале?

Программирование на паскале.

Найти среднее арифметическое положительных чётных чисел натурального ряда до N.

(Использование цикличного оператора for).

Randy322 17 нояб. 2020 г., 09:15:42 | 5 - 9 классы

Напишите программу для вычисления n - й степени числа x?

Напишите программу для вычисления n - й степени числа x.

Вычисление описать каждым из трех вариантов оператора цикла : For.

To. do, While.

Do, Repeat.

Until.

RedFox777 3 июл. 2020 г., 09:17:36 | 10 - 11 классы

Pascal вычислить сумму 1 ^ 4 + 2 ^ 4 + ?

Pascal вычислить сумму 1 ^ 4 + 2 ^ 4 + .

+ N ^ 4 (while, repeat until или For).

05sanek05 21 июл. 2020 г., 21:36:51 | 5 - 9 классы

Легкая задачка на циклы?

Легкая задачка на циклы.

ОБЯЗАТЕЛЬНО с циклами.

Pascal.

For…do, while…do и repeat…until любой.

Титан1 1 авг. 2020 г., 15:37:47 | 10 - 11 классы

Вычислите в цикле Repeat?

Вычислите в цикле Repeat.

Until.

Хрен62118 11 мая 2020 г., 18:36:10 | 10 - 11 классы

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0?

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0.

N вводится с клавиатуры.

Сделать нужно по 3 циклам в паскале (repeat until, for to do, while do).

Fifsangy1245 13 нояб. 2020 г., 10:36:26 | 5 - 9 классы

Составьте программу для вычисления суммы натуральных чисел от 20 до 99?

Составьте программу для вычисления суммы натуральных чисел от 20 до 99.

Решите задачку в двух вариантах - с использованием операторов while и repeat.

СРОЧНО ПОЖАЛУЙСТА ПОМОГИТЕ.

Полина952 25 дек. 2020 г., 10:19:56 | 10 - 11 классы

Цикл while, for или repeat, помогите пожалуйста решить задачу?

Цикл while, for или repeat, помогите пожалуйста решить задачу.

Veravolf 21 дек. 2020 г., 23:22:17 | 5 - 9 классы

Составьте программу вычисления суммы натуральных чисел от 20 до 99 с использованием оператора for?

Составьте программу вычисления суммы натуральных чисел от 20 до 99 с использованием оператора for.

Вы перешли к вопросу Вычислить сумму первых N чисел натурального ряда?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.