Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0?

Информатика | 10 - 11 классы

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0.

N вводится с клавиатуры.

Сделать нужно по 3 циклам в паскале (repeat until, for to do, while do).

Ответить на вопрос
Ответы (1)
Katya720 11 мая 2020 г., 18:36:15

Var i, n, s : integer ;

begin readln(n) ; i : = 0 ; s : = 0 ; while i < ; 7 do begin if (n mod 2 = 1) then begin s : = s + n ; i : = i + 1 ; end ; n : = n + 1 ; end ; writeln(s) ;

end.

Var i, n, s : integer ;

begin readln(n) ; i : = 0 ; s : = 0 ; repeat if (n mod 2 = 1) then begin s : = s + n ; i : = i + 1 ; end ; n : = n + 1 ; until i > ; = 7 ; writeln(s) ;

end.

Var i, n, s : integer ;

begin readln(n) ; n : = n + (n + 1) mod 2 ; s : = 0 ; for i : = 1 to 7 do begin s : = s + n ; writeln(n) ; n : = n + 2 ; end ; writeln(s) ;

end.

Earth3 11 июл. 2020 г., 18:52:48 | 10 - 11 классы

Помогиииитееее?

Помогиииитееее!

На паскале

1.

Найти сумму первых 10 натуральных нечетных чисел.

2. Найти произведение натуральных чисел прекратить подсчет при вводе 1.

Всенорм1 30 окт. 2020 г., 12:17:06 | 10 - 11 классы

Найти сумму N чисел натурального ряда кратных 7, начиная с k> ; 0, N> ; 0, N и K вводятся с клавиатуры?

Найти сумму N чисел натурального ряда кратных 7, начиная с k> ; 0, N> ; 0, N и K вводятся с клавиатуры.

Cашка123 12 мар. 2020 г., 20:58:34 | 5 - 9 классы

Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n - вводится с клавиатуры) если n - четное, и сумму кубов чисел от 1 до n, если n - нечетное?

Составьте программу вычисляющую, сумму квадратов чисел от 1 до n, (n - вводится с клавиатуры) если n - четное, и сумму кубов чисел от 1 до n, если n - нечетное.

Использовать цикл WHILE.

Kir71 3 окт. 2020 г., 07:05:30 | 5 - 9 классы

С клавиатуры вводится натуральное число k, затем последовательно вводится k чисел с плавающей точкой?

С клавиатуры вводится натуральное число k, затем последовательно вводится k чисел с плавающей точкой.

Найти сумму этих чисел и наименьшее них.

Паскаль.

Fafa222 20 февр. 2020 г., 15:29:03 | 5 - 9 классы

С клавиатуры вводятся 17 чисел?

С клавиатуры вводятся 17 чисел.

Найти произведение положительных чисел не делящихся на 17.

Решить в паскале, методом repeat.

Until.

05sanek05 21 июл. 2020 г., 21:36:51 | 5 - 9 классы

Легкая задачка на циклы?

Легкая задачка на циклы.

ОБЯЗАТЕЛЬНО с циклами.

Pascal.

For…do, while…do и repeat…until любой.

Матемк 8 мая 2020 г., 20:59:19 | 10 - 11 классы

Найти сумму 10 натуральных чисел (использовать цикл While)?

Найти сумму 10 натуральных чисел (использовать цикл While).

Мая15 5 сент. 2020 г., 22:47:47 | 10 - 11 классы

Сумма нечетных 5 чисел на паскале Найти сумму 5 нечетных чисел натурально ряда n> ; 0?

Сумма нечетных 5 чисел на паскале Найти сумму 5 нечетных чисел натурально ряда n> ; 0.

Никитакиоссе2 10 нояб. 2020 г., 21:02:09 | 10 - 11 классы

Вычислить сумму первых N чисел натурального ряда?

Вычислить сумму первых N чисел натурального ряда.

С использованием операторов цикла For - To (или For - Downto), While - Do и Repeat - Until.

Паскаль.

JIJKKJK 17 нояб. 2020 г., 19:35:24 | 10 - 11 классы

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0?

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0.

. N вводится с клавиатуры.

Перед вами страница с вопросом Найти сумму семи нечетных чисел натурального ряда, начиная с N&gt ; 0?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.