Напишите программу для вычисления n - й степени числа x?

Информатика | 5 - 9 классы

Напишите программу для вычисления n - й степени числа x.

Вычисление описать каждым из трех вариантов оператора цикла : For.

To. do, While.

Do, Repeat.

Until.

Ответить на вопрос
Ответы (1)
Fedianin98 17 нояб. 2020 г., 09:15:44

Язык программирования Паскаль?

Program ANT ;

var x, F : real ;

var n : integer ;

begin

writeln('Введите x') ;

readln(x) ;

writeln('Введите n') ;

readln(n) ;

while x> ; = 0 dobegin

F : = exp(n * ln(x)) ;

write('F = ') ;

writeln(f : 4 : 2) ;

end ;

readln ;

end.

Sami4 30 окт. 2020 г., 16:43:44 | 10 - 11 классы

Какие слова не используется в команде цикла с предусловием A)While B)repeat С)do D)Until?

Какие слова не используется в команде цикла с предусловием A)While B)repeat С)do D)Until.

Lex766 23 дек. 2020 г., 05:25:58 | 5 - 9 классы

Составить программу с использованием циклических конструкций While… do… и Repeat… Until…?

Составить программу с использованием циклических конструкций While… do… и Repeat… Until….

222нез 12 мая 2020 г., 02:56:06 | 10 - 11 классы

Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat?

Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat.

Until, While.

Do, For.

To). Найти среднее арифметическое этих чисел.

05sanek05 21 июл. 2020 г., 21:36:51 | 5 - 9 классы

Легкая задачка на циклы?

Легкая задачка на циклы.

ОБЯЗАТЕЛЬНО с циклами.

Pascal.

For…do, while…do и repeat…until любой.

Никитакиоссе2 10 нояб. 2020 г., 21:02:09 | 10 - 11 классы

Вычислить сумму первых N чисел натурального ряда?

Вычислить сумму первых N чисел натурального ряда.

С использованием операторов цикла For - To (или For - Downto), While - Do и Repeat - Until.

Паскаль.

Хрен62118 11 мая 2020 г., 18:36:10 | 10 - 11 классы

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0?

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0.

N вводится с клавиатуры.

Сделать нужно по 3 циклам в паскале (repeat until, for to do, while do).

Бeла 28 сент. 2020 г., 10:39:50 | 10 - 11 классы

С# Решите задачу тремя способами - используя операторы цикла while, do while и for?

С# Решите задачу тремя способами - используя операторы цикла while, do while и for.

Вывести на экран : все целые числа из диапазона от А до В, кратные трем (А< ; = В) ;

79685425752 6 нояб. 2020 г., 03:54:58 | 10 - 11 классы

Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE?

Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет посредством цикла WHILE.

DO, а вывод – REPEAT.

UNTIL (в скобках указана размерность массива)

1.

Подсчитать произведение неотрицательных элементов в двухмерном массиве 6 × 3 ;

Gbgbw 29 сент. 2020 г., 12:19:19 | 1 - 4 классы

Оператор цикла while ?

Оператор цикла while .

Do отличается от цикла for.

To, тем что

1.

Выполняется хотя бы один раз

2.

Выполняется хотя бы один раз

3.

Может не выполняться ни разу

4.

Выполняется известное число раз

5.

Выполняется неизвестное число раз.

Fifsangy1245 13 нояб. 2020 г., 10:36:26 | 5 - 9 классы

Составьте программу для вычисления суммы натуральных чисел от 20 до 99?

Составьте программу для вычисления суммы натуральных чисел от 20 до 99.

Решите задачку в двух вариантах - с использованием операторов while и repeat.

СРОЧНО ПОЖАЛУЙСТА ПОМОГИТЕ.

Перед вами страница с вопросом Напишите программу для вычисления n - й степени числа x?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.