Дано действительное число Х?

Информатика | 5 - 9 классы

Дано действительное число Х.

Напишите программу для вычисления : Числа Х, округлённого до ближайшего целого Числа Х без дробных цифр.

Ответить на вопрос
Ответы (1)
Katbagunova 15 окт. 2020 г., 13:30:41

В Паскале есть функция Round, которая использует следующий "стандартный" алгоритм округления :

Если число положительное, то при величине его дробной части меньше 0.

5, она просто отбрасывается, если больше - отбрасывается и к числу прибавляется единица.

Если число отрицательное, то при абсолютной величине его дробной части меньше 0.

5, она просто отбрасывается, если больше - из числа вычитается единица.

А функция Trunc возвращает целую часть числа.

Var p : real ;

begin Write('Введите число : ') ; Read(p) ; Writeln('Округленное значение : ', Round(p), ', целая часть : ', Trunc(p))

end.

Тестовое решение :

Введите число : - 12.

74

Округленное значение : - 13, целая часть : - 12

Введите число : 12.

93

Округленное значение : 13, целая часть : 12

Введите число : 9.

4323

Округленное значение : 9, целая часть : 9.

Iordanowaalena 16 авг. 2020 г., 09:24:16 | 5 - 9 классы

Дано вещественное число х напишите программу, которая вычисляет целую часть числа х, округленную до ближайшего целого, и выводит на экран монитора результат?

Дано вещественное число х напишите программу, которая вычисляет целую часть числа х, округленную до ближайшего целого, и выводит на экран монитора результат.

Winterbottom 13 июн. 2020 г., 22:55:51 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Составить программу нахождения количества цифр числа (Pascal ABC).

НАстик1111 10 нояб. 2020 г., 08:04:40 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые.

Keyyt 15 нояб. 2020 г., 18:29:11 | 10 - 11 классы

Даю 15 баллов?

Даю 15 баллов!

Напишите программу в паскале Дано целое трехзначное число N и целое число k.

Написать программу, подсчитывающую сумму тех цифр числа N, которые больше k.

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

Nastenkasergee 11 сент. 2020 г., 21:40:15 | 10 - 11 классы

Программу на Си?

Программу на Си.

Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

Dannykotov 10 мая 2020 г., 00:21:04 | 1 - 4 классы

Дано 2 - х значное число?

Дано 2 - х значное число.

Составит программу вычисления цифр данного числа пожалуйста помогите))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))) спс заранее.

Мухтар7 11 авг. 2020 г., 21:59:02 | 5 - 9 классы

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые?

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые.

LadyFrost 7 нояб. 2020 г., 23:10:11 | 10 - 11 классы

Дано действительное число R вида nnn?

Дано действительное число R вида nnn.

Ddd (три цифровых разряда в целой и дробной частях).

Поменять местами дробную и целую части числа и вывести полученное значение числа.

Vksolopova 6 мар. 2020 г., 16:16:29 | 10 - 11 классы

Даны два целых двузначных числа?

Даны два целых двузначных числа.

Верное ли, что все цифры первого числа больше соответствующих цифр второго числа?

Написать программу для Pascal.

На этой странице сайта размещен вопрос Дано действительное число Х? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.