Дано действительное число R вида nnn?

Информатика | 10 - 11 классы

Дано действительное число R вида nnn.

Ddd (три цифровых разряда в целой и дробной частях).

Поменять местами дробную и целую части числа и вывести полученное значение числа.

Ответить на вопрос
Ответы (1)
Pavlua 7 нояб. 2020 г., 23:10:15

/ / PascalABC.

NET 3.

1, сборка 1198 от 11.

03. 2016

begin var s : = ReadReal('r = ').

ToString ; var p : = Pos('.

', s) ; Writeln(Copy(s, p + 1, 3) + '.

' + Copy(s, p - 3, 3))

end.

Тестовое решение :

r = 234.

652

652.

234.

Ovikoganyan 27 нояб. 2020 г., 05:31:19 | 5 - 9 классы

Какие формы записи используются для вещественных чисел?

Какие формы записи используются для вещественных чисел?

Выберите один ответ : с конечным числом разрядов и с бесконечным числом разрядов двоичная и десятичная с фиксированной точкой и с плавающей точкой с дробной частью и без дробной части.

Angal0 27 апр. 2020 г., 11:10:19 | 10 - 11 классы

Даны 2 числа в двоичном виде?

Даны 2 числа в двоичном виде.

В первом числе поменять местами старшую и младшую части числа.

Во втором - 1 - ый и 4 - ый разряды поменять местами с 3 - м и 7 - мым разрядами соответственно.

Результаты логически сложить и умножить на 4.

Nmizqalew 15 окт. 2020 г., 13:30:35 | 5 - 9 классы

Дано действительное число Х?

Дано действительное число Х.

Напишите программу для вычисления : Числа Х, округлённого до ближайшего целого Числа Х без дробных цифр.

Lenchik364 10 окт. 2020 г., 22:25:45 | 10 - 11 классы

В данном целом числе N, заменить нулями все четные цифры в данном числе?

В данном целом числе N, заменить нулями все четные цифры в данном числе.

Вывести полученное число.

(Паскаль).

Помогитесуровнением 26 мар. 2020 г., 13:24:02 | 10 - 11 классы

Дано вещественное число?

Дано вещественное число.

Вывести на экран его абсольтную величину , если число отрицательное, или дробную часть в противном случае.

Darya08052000 30 мая 2020 г., 12:27:30 | 10 - 11 классы

Дано целое число ?

Дано целое число .

Если оно является положительным, то умножить его на 3 ; в противном случае не изменять его.

Вывести полученное число.

Saharus96 4 нояб. 2020 г., 20:13:50 | 5 - 9 классы

Любое целое число можно рассматривать как вещественное но с нулевой дробной частью обоснуйте целесообразность наличия особых способов компьютерного представления целых чисел?

Любое целое число можно рассматривать как вещественное но с нулевой дробной частью обоснуйте целесообразность наличия особых способов компьютерного представления целых чисел.

Liubavamura 30 сент. 2020 г., 04:53:32 | 5 - 9 классы

Первый вопрос функция Frac (x) позволяет : А найти дробную часть числа х?

Первый вопрос функция Frac (x) позволяет : А найти дробную часть числа х.

В найти целую часть числа х.

С найти квадрат числа х.

Д округлить число до ближайшего целого.

888Diana888 11 нояб. 2020 г., 17:02:10 | 5 - 9 классы

Запиши развёрнутую запись числа 0, 523 для дробной части числа?

Запиши развёрнутую запись числа 0, 523 для дробной части числа.

Kzh1444 19 сент. 2020 г., 22:34:50 | 5 - 9 классы

Записать программу которая по двум введеным числам находит сумму дробных частей и сумму целых частей?

Записать программу которая по двум введеным числам находит сумму дробных частей и сумму целых частей.

На языке ПАСКАЛЕ.

Если вам необходимо получить ответ на вопрос Дано действительное число R вида nnn?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.