Программу на Си?

Информатика | 10 - 11 классы

Программу на Си.

Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

Ответить на вопрос
Ответы (1)
DaryAneGuy 11 сент. 2020 г., 21:40:18

#include < ; stdio.

H> ;

int main()

{ int a ; scanf("%d", & ; a) ; for(int i = 100 ; i < ; 1000 ; i + + ) { if((i % 10 + ((i % 100 - i % 10) / 10) + (((i - i % 10 ) / 10) - i % 10) / 10)) = = a) { printf("%d", i) ; } }

}

Правда это слегка кустарный способ решения.

Wedoma 27 апр. 2020 г., 02:36:46 | 5 - 9 классы

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом?

1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом.

2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом.

8 класс.

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

Keyyt 15 нояб. 2020 г., 18:29:11 | 10 - 11 классы

Даю 15 баллов?

Даю 15 баллов!

Напишите программу в паскале Дано целое трехзначное число N и целое число k.

Написать программу, подсчитывающую сумму тех цифр числа N, которые больше k.

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

Pinilopa1 28 февр. 2020 г., 11:46:17 | 1 - 4 классы

Даны целое трехзначное число N и цедое число k?

Даны целое трехзначное число N и цедое число k.

Написать программу, подсчитывающую сумму цифр числа N, которые больше k.

Fatik41 21 мар. 2020 г., 13:20:24 | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Egor200114 5 янв. 2020 г., 18:50:16 | 10 - 11 классы

Помогите, всё что сможете?

Помогите, всё что сможете!

5) С помощью repeat напишите программу, которая требует у вас пароль, например 111.

Если пароль правильный, то заполняет все строки экрана сообщением «Молодец».

Если после пятой попытки пароль все равно неверен, выходит из программы.

(2 балла) 21) Составьте программу вычисления степени числа A с натуральным показателем N.

Записать варианты программы со всеми видами циклов : while, repeat, for.

(3 балла) 27) Составьте программу, которая выводит полную запись десятичного числа 42 * 4 * , в которой пропущены две цифры (обозначены * ), если известно, что данное число кратно 72.

(4 балла) 1) Найти все двузначные числа, сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8, 9.

2) Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

3) Найти все трехзначные числа, средняя цифра которых равна сумме первой и второй цифр.

4) Найти все трехзначные числа, которые можно представить разностью между квадратом числа, образованного первыми двумя цифрами и квадратом третьей цифры.

5) Найти все двузначные числа, сумма квадратов цифр которых делится на 17.

6) Найти все трехзначные числа, представимые в виде сумм факториалов своих цифр.

7) Найти двузначное число, обладающее тем свойством, что куб суммы его цифр равен квадрату самого числа.

8) Найти двузначное число, равное утроенному произведению его цифр.

9) В каких двузначных числах удвоенная сумма цифр равна их произведению?

10) Можно ли заданное натуральное число М представить в виде суммы квадратов двух натуральных чисел?

Написать программу решения этой задачи.

Arininaira 17 июн. 2020 г., 08:15:08 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Составьте программу, выводящую на экран все трехзначные числа, сумма цифр которых равна 10.

Мухтар7 11 авг. 2020 г., 21:59:02 | 5 - 9 классы

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые?

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые.

Котубийца 1 авг. 2020 г., 08:24:58 | 5 - 9 классы

Задача по информатике?

Задача по информатике.

Найти сумму цифр данного целого числа.

Программа.

Паскаль.

На этой странице находится вопрос Программу на Си?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.