Массив А вводится с клавиатуры?

Информатика | 5 - 9 классы

Массив А вводится с клавиатуры.

Найти среднее арифметическое его элементов с нечетными номерами.

Размер вводим с клавиатуры (< ; = 20).

Ответить на вопрос
Ответы (1)
Dvoychenkova98 6 февр. 2020 г., 04:57:17

Program qwer ;

uses crt ;

var a : array [1.

50] of integer ;

sum, kol, i, raz : integer ;

Begin

sum : = 0 ; kol : = 0 ;

write('Размер : ') ; readln(raz) ;

for i : = 1 to raz do

begin

readln(a[i]) ;

if i mod 2 = 1 then

begin

kol : = kol + 1 ; sum : = sum + a[i] ;

end ;

end ;

write('Cреднее арифметическое : ', sum / kol) ;

End.

Kashetay 27 февр. 2020 г., 07:31:35 | 5 - 9 классы

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры?

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры.

Подсчитать среднее арифметическое элементов с нечетными номерами.

Nancy19 23 июн. 2020 г., 08:18:59 | 10 - 11 классы

10. Дан одномерный массив?

10. Дан одномерный массив.

К четным элементам массива прибавить В, а из нечетных вычесть С.

Значения В и С вводятся с клавиатуры.

130880 26 нояб. 2020 г., 07:12:46 | 10 - 11 классы

Помогите решить задачи?

Помогите решить задачи!

1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести максимальный элемент данного массива и его номер.

2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести все двузначные элементы массива и их номера.

3. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести предпоследний элемент массива кратный 3 и его номер.

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Yytffed 16 окт. 2020 г., 13:57:24 | 10 - 11 классы

Информатика?

Информатика.

Массивы Массив A вводится с клавиатуры.

Сформировать новый массив B, состоящий из чётны элементов массива А.

Элементы вводятся с клавиатуры.

Размер произвольный.

Egormama 9 мар. 2020 г., 20:31:59 | 5 - 9 классы

Найти наибольший элемент и его номер в последовательности, элементы которой вводятся с клавиатуры?

Найти наибольший элемент и его номер в последовательности, элементы которой вводятся с клавиатуры.

Размер произвольный.

Nadiika 31 авг. 2020 г., 05:17:20 | 5 - 9 классы

Массив А вводится с клавиатуры?

Массив А вводится с клавиатуры.

Найти сумму его элементов.

Размер произвольный.

Паскаль.

Bykaa 19 сент. 2020 г., 02:44:48 | 5 - 9 классы

Помогите решить задачу Найти сумму элементов одномерного массива?

Помогите решить задачу Найти сумму элементов одномерного массива.

Размер произвольный.

Элементы вводятся с клавиатуры.

Appland4569 19 нояб. 2020 г., 15:04:46 | 5 - 9 классы

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ1?

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ

1.

Задан массив А, состоящий из n чисел.

Найти среднее арифметическое его элементов.

Элементы вводятся с клавиатуры.

2. Найти сумму элементов массива с четными номерами, содержащего N элементов.

Элементы вводятся с клавиатуры.

3. Дан одномерный массив, значения элементов которого вводятся с клавиатуры.

Выяснить, каких элементов больше - положительных или отрицательных и насколько.

На экран вывести исходный массив и полученный результат.

Вы открыли страницу вопроса Массив А вводится с клавиатуры?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.