Помогите решить задачи?

Информатика | 10 - 11 классы

Помогите решить задачи!

1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести максимальный элемент данного массива и его номер.

2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести все двузначные элементы массива и их номера.

3. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести предпоследний элемент массива кратный 3 и его номер.

Ответить на вопрос
Ответы (1)
Лизольдоу 26 нояб. 2020 г., 07:12:49

1)

var a = array[1.

10]of integer ;

i, max, poz : integer ;

begin

writeln('vverite 10 elementov')

for i : = 1 to 10 do

read(a[i]) ;

max : = a[1] ;

poz : = 1 ;

for i : = 2 to 10 do

if (a[i]> ; max)then begin max : = a[i] ; poz : = i ; end ;

writeln('max = ', max, ' ego nomer = ', poz) ;

end.

2)

var a = array[1.

10]of integer ;

i : integer ;

begin

writeln('vverite 10 elementov')

for i : = 1 to 10 do

read(a[i]) ;

for i : = 1 to 10 do

if (a[i]> ; = 10)and(a[i]< ; = 99) then writeln(a[i], ' egonomer', i) ;

end.

3)

var a = array[1.

10]of integer ;

i, k, poz : integer ;

begin

writeln('vverite 10 elementov')

for i : = 1 to 10 do

read(a[i]) ;

k : = 0 ;

for i : = 10downto 1 do

begin

if(a[i] mod 3 = 0) then begink : = k + 1 ; poz : = i ; end ;

if(k = 2) then writeln(a[i], ' ego nomer = ', i) ;

end ;

if(k = 0) then writeln('kratnyh 3 net') ;

if(k = 1) then writeln('kratnyy 3 tol'ko 1 : a[', poz, '] = ', a[poz]) ;

end.

СеРёЖкА2708 6 янв. 2020 г., 01:30:20 | 10 - 11 классы

В целочисленный числовой массив из тридцати элементов значения вводятся с клавиатуры?

В целочисленный числовой массив из тридцати элементов значения вводятся с клавиатуры.

Составьте программу на одном из языков программирования, которая в данном числовом массиве находит три последовательных элемента, сумма которых максимальна.

Если таких троек несколько, то выбрать тройку с наименьшими порядковыми номерами.

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

Christina1996 1 мар. 2020 г., 05:09:50 | 5 - 9 классы

Помогите решить задачи на дом : 1) Найти сумму элементов массива, больших данного числа b ( b вводится с клавиатуры) 2) Есть ли в данном массиве элементы равные заданному числу?

Помогите решить задачи на дом : 1) Найти сумму элементов массива, больших данного числа b ( b вводится с клавиатуры) 2) Есть ли в данном массиве элементы равные заданному числу?

Если есть, то вывести номер одного из них.

Kalashnikova18 12 сент. 2020 г., 07:57:56 | 5 - 9 классы

Дан массив размера N?

Дан массив размера N.

Вывести минимальный элемент данного массива и его номер.

Margo4115 20 июн. 2020 г., 17:50:09 | 5 - 9 классы

Задан массив из 12 вещественных чисел?

Задан массив из 12 вещественных чисел.

Поменять местами два элемента массива, номера которых вводятся с клавиатуры.

Вывести элемент после замены.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Yytffed 16 окт. 2020 г., 13:57:24 | 10 - 11 классы

Информатика?

Информатика.

Массивы Массив A вводится с клавиатуры.

Сформировать новый массив B, состоящий из чётны элементов массива А.

Элементы вводятся с клавиатуры.

Размер произвольный.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

IldarAWM 2 дек. 2020 г., 16:47:58 | 5 - 9 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Массивы На паскале.

Даю 50 баллов Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти : •вывести индексы тех элементов, значения которых больше заданного числа А ; •определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Appland4569 19 нояб. 2020 г., 15:04:46 | 5 - 9 классы

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ1?

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ

1.

Задан массив А, состоящий из n чисел.

Найти среднее арифметическое его элементов.

Элементы вводятся с клавиатуры.

2. Найти сумму элементов массива с четными номерами, содержащего N элементов.

Элементы вводятся с клавиатуры.

3. Дан одномерный массив, значения элементов которого вводятся с клавиатуры.

Выяснить, каких элементов больше - положительных или отрицательных и насколько.

На экран вывести исходный массив и полученный результат.

На этой странице сайта вы найдете ответы на вопрос Помогите решить задачи?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.