3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ1?

Информатика | 5 - 9 классы

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ

1.

Задан массив А, состоящий из n чисел.

Найти среднее арифметическое его элементов.

Элементы вводятся с клавиатуры.

2. Найти сумму элементов массива с четными номерами, содержащего N элементов.

Элементы вводятся с клавиатуры.

3. Дан одномерный массив, значения элементов которого вводятся с клавиатуры.

Выяснить, каких элементов больше - положительных или отрицательных и насколько.

На экран вывести исходный массив и полученный результат.

Ответить на вопрос
Ответы (1)
Самигулла 19 нояб. 2020 г., 15:04:52

/ / PascalABC.

Net 3.

2

{1}

begin

var a : = readArrinteger('Вводите : ', readinteger('n = ')) ;

write ('Ср.

Арифметическое : ', a.

Average) ;

end.

{2}

begin

var a : = readarrinteger('Водите : ', readinteger('n = ')) ;

var sum : = 0 ;

for var i : = 0 to length(a) - 1 do if i.

Isodd then sum + = a[i] ;

write ('Сумма : ', sum) ;

end.

{3}

begin

var a : = readarrinteger('Вводите : ', readinteger('Кол - во элементов : ')) ;

var otr : = 0 ; var pol : = 0 ;

for var i : = 0 to length(a) - 1 do if a[i]pol then write('Отрицательных больше на ', otr - pol) else

write ('Положительных больше на ', pol - otr) ;

end.

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Margo4115 20 июн. 2020 г., 17:50:09 | 5 - 9 классы

Задан массив из 12 вещественных чисел?

Задан массив из 12 вещественных чисел.

Поменять местами два элемента массива, номера которых вводятся с клавиатуры.

Вывести элемент после замены.

Zabello98 17 нояб. 2020 г., 02:59:16 | 10 - 11 классы

Дан одномерный массив состоящий из 30 элементов целого типа?

Дан одномерный массив состоящий из 30 элементов целого типа.

Найти произведение элементов массива, больше некоторого Х (вводится пользователем с клавиатуры) вывести результат на экран.

Нарисовать блок схему.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Sveti4ek2000 8 дек. 2020 г., 16:46:15 | 10 - 11 классы

Создать одномерный массив, содержащий целые числа?

Создать одномерный массив, содержащий целые числа.

Элементы массива вводятся с клавиатуры.

Найти номера всех элементов больше 5 (вывести их на экран), если таких нет, то сообщить об этом.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

5555165 12 окт. 2020 г., 08:39:12 | 10 - 11 классы

Дан одномерный массив, состоящий из 10 элементов?

Дан одномерный массив, состоящий из 10 элементов.

Значение элементов вводятся с клавиатуры.

Значения могут быть как положительные так и отрицательные.

Найдите сумму четных положительных элементов.

Результат вывести на форму.

IldarAWM 2 дек. 2020 г., 16:47:58 | 5 - 9 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Массивы На паскале.

Даю 50 баллов Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти : •вывести индексы тех элементов, значения которых больше заданного числа А ; •определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Вы зашли на страницу вопроса 3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ1?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.