Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры?

Информатика | 5 - 9 классы

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры.

Подсчитать среднее арифметическое элементов с нечетными номерами.

Ответить на вопрос
Ответы (1)
Lenka2012vs 27 февр. 2020 г., 07:31:36

Var a : array[1.

6] of integer ; i, k, s : integer ;

begin

for i : = 1 to 6 do read(a[i]) ;

k : = 0 ; s : = 0 ;

for i : = 1 to 6 do

if i mod 2 = 1 then begin k : = k + 1 ; s : = s + a[i] ; end ;

writeln('Среднее арифметическое элементов массива с нечетными номерами = ', s / k) ;

end.

Zemkafr 24 мар. 2020 г., 01:18:15 | 10 - 11 классы

Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n - задано с клавиатуры?

Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n - задано с клавиатуры.

Найти их среднее арифметическое значение.

Anutka19998 2 мая 2020 г., 20:21:46 | 10 - 11 классы

Массив А(N, M)?

Массив А(N, M).

В каждом столбце найти среднее арифметическое нечетных элементов.

Из полученных значений сформировать одномерный массив.

Nastena2805 2 апр. 2020 г., 04:43:43 | 10 - 11 классы

Погите пожалуйста?

Погите пожалуйста.

Нужно написать задачи на языке Паскаль.

1. С клавиатуры заполнить целочисленный одномерный массив.

Вывести неотрицательные элементы массива.

2. дан одномерный массив целых чисел.

Определить каких элементов больше, максимальных и минимальных 3.

Дан одномерный массив целых чисел.

Подсчитать количество элементов, равных заданному массиву x.

Число х вводится с клавиатуры.

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Irka1234 24 авг. 2020 г., 20:28:40 | 10 - 11 классы

(1) вариант1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > ; 28 и их среднее арифметическое2 написать программу которая?

(1) вариант

1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > ; 28 и их среднее арифметическое

2 написать программу которая выводит с клавиатуры одномерный массив из 6 целых чисел и выводит нечётные

3 написать программу ввода с клавиатуры последовательность целых чисел вычисляющую кол - во и сумму положительно ввёдных чисел.

Ilimavtovaz 6 февр. 2020 г., 04:57:11 | 5 - 9 классы

Массив А вводится с клавиатуры?

Массив А вводится с клавиатуры.

Найти среднее арифметическое его элементов с нечетными номерами.

Размер вводим с клавиатуры (< ; = 20).

75281 13 июн. 2020 г., 10:59:13 | 10 - 11 классы

Написать программу, которая вводит с клавиатуры одномерный массив из пяти целых чисел и выводит количество ненулевых элементов?

Написать программу, которая вводит с клавиатуры одномерный массив из пяти целых чисел и выводит количество ненулевых элементов.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Fatima101 9 окт. 2020 г., 22:52:32 | 5 - 9 классы

1) Дан массив целых чисел?

1) Дан массив целых чисел.

Подсчитать сумму элементов с четными индексами.

2)Дан одномерный массив, состоящий из 20 элементов.

Подсчитать количество элементов, превышающих по значению его среднее арифметическое.

Appland4569 19 нояб. 2020 г., 15:04:46 | 5 - 9 классы

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ1?

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ

1.

Задан массив А, состоящий из n чисел.

Найти среднее арифметическое его элементов.

Элементы вводятся с клавиатуры.

2. Найти сумму элементов массива с четными номерами, содержащего N элементов.

Элементы вводятся с клавиатуры.

3. Дан одномерный массив, значения элементов которого вводятся с клавиатуры.

Выяснить, каких элементов больше - положительных или отрицательных и насколько.

На экран вывести исходный массив и полученный результат.

Перед вами страница с вопросом Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.