10. Дан одномерный массив?

Информатика | 10 - 11 классы

10. Дан одномерный массив.

К четным элементам массива прибавить В, а из нечетных вычесть С.

Значения В и С вводятся с клавиатуры.

Ответить на вопрос
Ответы (1)
Катюша2002паркег 23 июн. 2020 г., 08:19:02

Var

a : array[1?

Сколько у тебя элементов в массиве?

] of integer ;

b, c, i : integer ;

begin

read(b, c) ;

for i : = 1 to / kol - vo elementov v massive / do

begin

read(a[i]) ;

write(a[i], ' ') ;

end ;

writeln

for i : = 1 to / kol - vo elementov v massive / do

begin

if i mod 2 = 0 then

a[i] : = a[i] + b

else

a[i] : = a[i] - c ;

write(a[i], ' ')

end ;

end.

Combo27 24 окт. 2020 г., 15:07:29 | 10 - 11 классы

Сделать одномерный массив?

Сделать одномерный массив.

В массив A[N] занесены натуральные числа.

Найти сумму тех элементов, каторые кратны данному значению К.

Элементы массива вводить с клавиатуры.

Alesya0501 19 апр. 2020 г., 23:12:06 | 10 - 11 классы

Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры)?

Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры).

Обнулите значения всех элементов с нечетными индексами.

Выведите значения одномерного массива в строку через пробел.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Таантя 26 сент. 2020 г., 19:41:16 | 5 - 9 классы

1. Дан одномерный массив из N элементов?

1. Дан одномерный массив из N элементов.

Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2.

Дан одномерный массив из Н элементов.

Найти среднее арифметическое положительных четных элементов данного массива.

Julia8282 3 дек. 2020 г., 11:36:00 | 5 - 9 классы

Дан одномерный массив, состоящий из N элементов?

Дан одномерный массив, состоящий из N элементов.

Найти максимальный из нечетных элементов массива.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Wapiro 15 июн. 2020 г., 23:50:17 | 5 - 9 классы

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива(числа вводятся с клавиатуры)?

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива

(числа вводятся с клавиатуры).

Artem1918 1 янв. 2020 г., 05:23:47 | 10 - 11 классы

Создать два одномерных массива, состоящих из целых чисел?

Создать два одномерных массива, состоящих из целых чисел.

Элементы массива вводятся с клавиатуры.

В первом массиве найти номер первого нечетного элемента массива.

Во втором массиве найти первый четный элемент массива.

Решить на Pascal ABC (При решении задач обязательно использовать одномерные массивы и процедуры или функции работы с одномерными массивами.

).

5555165 12 окт. 2020 г., 08:39:12 | 10 - 11 классы

Дан одномерный массив, состоящий из 10 элементов?

Дан одномерный массив, состоящий из 10 элементов.

Значение элементов вводятся с клавиатуры.

Значения могут быть как положительные так и отрицательные.

Найдите сумму четных положительных элементов.

Результат вывести на форму.

НастяЕлизарова 12 сент. 2020 г., 02:22:04 | 5 - 9 классы

Составьте программу ввода с клавиатуры элементов массива а [1?

Составьте программу ввода с клавиатуры элементов массива а [1.

10] и вывода на экран элементов с четными значениями и четными индексами.

На этой странице вы найдете ответ на вопрос 10. Дан одномерный массив?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.