Информатика?

Информатика | 10 - 11 классы

Информатика.

Массивы Массив A вводится с клавиатуры.

Сформировать новый массив B, состоящий из чётны элементов массива А.

Элементы вводятся с клавиатуры.

Размер произвольный.

Ответить на вопрос
Ответы (1)
Незнейтерарод 16 окт. 2020 г., 13:57:29

Const n = 10 ;

var a, b : array[1.

N] of integer ;

i, j : integer ;

begin

writeln('Введите ', n, ' чисел') ;

for i : = 1 to n do readln(a[i]) ;

j : = 0 ;

for i : = 1 to n do

if a[i] mod 2 = 0 then begin j : = j + 1 ; b[j] : = a[i] ; end ;

writeln('Полученный массив : ') ;

for i : = 1 to j do write(b[i], ' ') ;

writeln ;

end.

Пример :

Введите 10 чисел

45

65

12

78

14

47

16

62

42

38

Полученный массив :

12 78 14 16 62 42 38.

130880 26 нояб. 2020 г., 07:12:46 | 10 - 11 классы

Помогите решить задачи?

Помогите решить задачи!

1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести максимальный элемент данного массива и его номер.

2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести все двузначные элементы массива и их номера.

3. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести предпоследний элемент массива кратный 3 и его номер.

Ira20120 1 авг. 2020 г., 15:03:14 | 10 - 11 классы

Создать массив из пяти чисел вводом с клавиатуры и посчитать сумму элементов массива(в паскале)?

Создать массив из пяти чисел вводом с клавиатуры и посчитать сумму элементов массива(в паскале).

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Кубишка 18 июл. 2020 г., 12:57:53 | 10 - 11 классы

В массиве подсчитать : сумму чётных элементов?

В массиве подсчитать : сумму чётных элементов.

(Элементов массива : 7.

Массив вводится с клавиатуры).

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Vika19973 10 февр. 2020 г., 04:51:12 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Pretty36220 6 июл. 2020 г., 05:08:43 | 5 - 9 классы

Задача?

Задача.

Массив А вводится с клавиатуры.

Сформировать новый массив В , состоящий из положительных элементов массива А.

Размер произвольный.

Nadiika 31 авг. 2020 г., 05:17:20 | 5 - 9 классы

Массив А вводится с клавиатуры?

Массив А вводится с клавиатуры.

Найти сумму его элементов.

Размер произвольный.

Паскаль.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Bykaa 19 сент. 2020 г., 02:44:48 | 5 - 9 классы

Помогите решить задачу Найти сумму элементов одномерного массива?

Помогите решить задачу Найти сумму элементов одномерного массива.

Размер произвольный.

Элементы вводятся с клавиатуры.

Вы находитесь на странице вопроса Информатика? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.