Найти наибольший элемент и его номер в последовательности, элементы которой вводятся с клавиатуры?

Информатика | 5 - 9 классы

Найти наибольший элемент и его номер в последовательности, элементы которой вводятся с клавиатуры.

Размер произвольный.

Ответить на вопрос
Ответы (1)
Мыспапой 9 мар. 2020 г., 20:32:04

Будем считать, что ввод значения = 0 признак окончания ввода членов последовательности.

Тогда можно попробовать так :

var a, max, maxn, n : integer ;

begin readln(a) ; max : = a ; maxn : = 1 ; n : = 1 ; while a< ; > ; 0 do begin readln(a) ; n : = n + 1 ; if a> ; max then begin max : = a ; maxn : = n ; end ; end ; writeln('Максимальный : ', max, ' номер : ', maxn) ;

end.

Olyavoroshenko 15 мар. 2020 г., 20:32:40 | 10 - 11 классы

Дан массив из 10 элементов, которые вводятся с клавиатуры?

Дан массив из 10 элементов, которые вводятся с клавиатуры.

Найти : 1)наибольший элемент 2)Сумму неотрицаельных элементов 3)Произведение четных элементов.

130880 26 нояб. 2020 г., 07:12:46 | 10 - 11 классы

Помогите решить задачи?

Помогите решить задачи!

1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести максимальный элемент данного массива и его номер.

2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести все двузначные элементы массива и их номера.

3. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.

Вывести предпоследний элемент массива кратный 3 и его номер.

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Ilimavtovaz 6 февр. 2020 г., 04:57:11 | 5 - 9 классы

Массив А вводится с клавиатуры?

Массив А вводится с клавиатуры.

Найти среднее арифметическое его элементов с нечетными номерами.

Размер вводим с клавиатуры (< ; = 20).

Vika19973 10 февр. 2020 г., 04:51:12 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Pretty36220 6 июл. 2020 г., 05:08:43 | 5 - 9 классы

Задача?

Задача.

Массив А вводится с клавиатуры.

Сформировать новый массив В , состоящий из положительных элементов массива А.

Размер произвольный.

ЛенаК010 22 апр. 2020 г., 07:08:57 | 10 - 11 классы

Найти наибольшее число, кратное 3, в матрице размером mxn, элементы которой вводятся с клавиатуры?

Найти наибольшее число, кратное 3, в матрице размером mxn, элементы которой вводятся с клавиатуры.

Pascal.

Yytffed 16 окт. 2020 г., 13:57:24 | 10 - 11 классы

Информатика?

Информатика.

Массивы Массив A вводится с клавиатуры.

Сформировать новый массив B, состоящий из чётны элементов массива А.

Элементы вводятся с клавиатуры.

Размер произвольный.

Nadiika 31 авг. 2020 г., 05:17:20 | 5 - 9 классы

Массив А вводится с клавиатуры?

Массив А вводится с клавиатуры.

Найти сумму его элементов.

Размер произвольный.

Паскаль.

Bykaa 19 сент. 2020 г., 02:44:48 | 5 - 9 классы

Помогите решить задачу Найти сумму элементов одномерного массива?

Помогите решить задачу Найти сумму элементов одномерного массива.

Размер произвольный.

Элементы вводятся с клавиатуры.

Вы зашли на страницу вопроса Найти наибольший элемент и его номер в последовательности, элементы которой вводятся с клавиатуры?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.