1. Заполнить массив с клавиатуры целыми числами?

Информатика | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Ответить на вопрос
Ответы (1)
Tamila2333 18 нояб. 2020 г., 09:05:56

Const

n = 5 ;

var

a, b : array [1.

N] of integer ;

i, s, k1, k2, max, min : integer ;

begin

for i : = 1 to n do

readln (a[i]) ;

for i : = 1 to n do

writeln (i, ')elem = ', a[i]) ;

end.

Begin

for i : = 1 to n do

a[i] : = i * 3 ;

for i : = 1 to n do

writeln (i, ')elem = ', a[i]) ;

end.

Begin

s : = 0 ;

for i : = 1 to n do

begin

readln (a[i]) ;

s : = s + a[i] ;

end ;

writeln (s) ;

end.

Begin

k1 : = 0 ;

k2 : = 0 ;

for i : = 1 to n do

begin

readln (a[i]) ;

if a[i] > ; 0 then

k1 : = k1 + 1 ;

if a[i] < ; 0 then

k2 : = k2 + 1 ;

end ;

writeln (' + ', k1) ;

writeln (' - ', k2) ;

end.

Begin

k1 : = 0 ;

k2 : = 0 ;

for i : = 1 to n do

begin

readln (a[i]) ;

if (a[i] > ; 0) and (i mod 2 = 1) then k1 : = k1 + 1 ; if (a[i] < ; 0) and (i mod 2 = 0) then

k2 : = k2 + 1 ;

end ;

writeln (' + ', k1) ;

writeln (' - ', k2) ;

end.

Begin

for i : = 1 to n do

begin

readln (a[i]) ;

if a[i] < ; 0 then

b[i] : = sqr (a[i]) ;

if a[i] > ; 0 then

b[i] : = a[i] * a[i] * a[i] ;

end ;

for i : = 1 to n do

write (a[i], ' ') ;

writeln () ;

for i : = 1 to n do

write (b[i], ' ') ;

end.

Begin

for i : = 1 to n do

readln (a[i]) ;

max : = a[1] ; min : = a[1] ;

for i : = 2 to n do begin

if a[i] > ; max then

max : = a[i] ;

if a[i] < ; min then

min : = a[i] ;

end ;

writeln ('max = ', max) ;

writeln ('min = ', min) ;

end.

Begin

for i : = 1 to n do

readln (a[i]) ;

writeln ('found : ') ;

readln (s) ;

k1 : = 0 ; k2 : = 0 ;

for i : = n downto 1 do

if a[i] = s then

begin

k1 : = k1 + 1 ;

k2 : = i ;

end ;

writeln ('k = ', k1) ;

writeln ('i = ', k2) ;

end.

Бери те переменные, которые используются в конкретной программме.

Evgeniya198 23 мар. 2020 г., 23:05:18 | 5 - 9 классы

(Паскаль)Заполнить с клавиатуры массив из 10 элементов?

(Паскаль)Заполнить с клавиатуры массив из 10 элементов.

Вывести на экран те элементы массива, которые имеют четный номер и четное значение .

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Lera5762 22 дек. 2020 г., 07:31:29 | 5 - 9 классы

Заполнить массив размером 10 элементов целыми числами , вводимыми с клавиатуры ?

Заполнить массив размером 10 элементов целыми числами , вводимыми с клавиатуры .

Вывести на экран элементы массива и из произведения.

Tati123 25 февр. 2020 г., 11:27:23 | 5 - 9 классы

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры?

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры.

Яапелс 7 июн. 2020 г., 06:57:01 | 5 - 9 классы

С клавиатуры ввести массив А (Б)?

С клавиатуры ввести массив А (Б).

Найти сумму всех элементов массива.

Вывести ее на экран, и массив опять.

Klublena2011 27 июн. 2020 г., 01:58:52 | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Clashofclans080 30 нояб. 2020 г., 06:32:46 | 10 - 11 классы

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке?

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке.

Maneckoba0sha 21 апр. 2020 г., 16:28:40 | 10 - 11 классы

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный?

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент.

Sveti4ek2000 8 дек. 2020 г., 16:46:15 | 10 - 11 классы

Создать одномерный массив, содержащий целые числа?

Создать одномерный массив, содержащий целые числа.

Элементы массива вводятся с клавиатуры.

Найти номера всех элементов больше 5 (вывести их на экран), если таких нет, то сообщить об этом.

Перед вами страница с вопросом 1. Заполнить массив с клавиатуры целыми числами?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.