1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный?

Информатика | 10 - 11 классы

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент.

Ответить на вопрос
Ответы (1)
VikaGv 21 апр. 2020 г., 16:28:42

1)

const n = ?

; / / Сюда поставить любоенужное n

Var a : array[1.

N] of real ;

i, x, k : integer ; s : real ;

Begin

for i : = 1 to n do begin readln(x) ; a[i] : = x ; end ;

s : = 0 ;

k : = 0 ;

for i : = 1 to n do begin s : = s + a[i] ; k : = k + 1 ; end ;

s : = s / k ;

for i : = 1 to n do if a[i]< ; s then write(a[i], ', ') ;

s : = s / k ;

for i : = 1 to n do if a[i]< ; s then write(a[i], ', ') ;

readln ;

End.

2)

Const n = ?

;

Var a : array[1.

N] of integer ;

i, max, min : integer ;

Begin

for i : = 1 to n do begin readln(x) ; a[i] : = x ; end ;

min : = a[1] ;

max : = a[1] ;

for i : = 1 to n do if (i mod 2) = 0 then if a[i]> ; max then max : = a[i] ;

for i : = 1 to n do if (i mod 2)< ; > ; 0 then if a[i]< ; min then min : = a[i] ;

writeln('max = ', max) ;

writeln('min = ', min) ;

readln ;

End.

Evgeniya198 23 мар. 2020 г., 23:05:18 | 5 - 9 классы

(Паскаль)Заполнить с клавиатуры массив из 10 элементов?

(Паскаль)Заполнить с клавиатуры массив из 10 элементов.

Вывести на экран те элементы массива, которые имеют четный номер и четное значение .

Superelenarab 8 мая 2020 г., 17:14:42 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста!

Ввести c клавиатуры массив из 5 элементов, умножить их на 2 и вывести на экран.

Zhantonina 13 янв. 2020 г., 02:03:15 | 5 - 9 классы

(Pascal) Задача : Ввести массив из 5 элементов с клавиатуры?

(Pascal) Задача : Ввести массив из 5 элементов с клавиатуры.

Вывести элементы на экран и найти их сумму.

РЕШИТЕ ПОЗЯЗЯ!

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Tati123 25 февр. 2020 г., 11:27:23 | 5 - 9 классы

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры?

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры.

Яапелс 7 июн. 2020 г., 06:57:01 | 5 - 9 классы

С клавиатуры ввести массив А (Б)?

С клавиатуры ввести массив А (Б).

Найти сумму всех элементов массива.

Вывести ее на экран, и массив опять.

Clashofclans080 30 нояб. 2020 г., 06:32:46 | 10 - 11 классы

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке?

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке.

Artembabynin20 3 мая 2020 г., 13:07:17 | 10 - 11 классы

Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива?

Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Rnastichenko 13 окт. 2020 г., 07:24:06 | 10 - 11 классы

Ввести с клавиатуры массив из 5 элементов, найти в нем максимальный и минимальный элементы и их номера?

Ввести с клавиатуры массив из 5 элементов, найти в нем максимальный и минимальный элементы и их номера.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Вы открыли страницу вопроса 1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.