Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Информатика | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

Ответить на вопрос
Ответы (1)
Anjutaandreeva 27 июн. 2020 г., 01:58:53

Const n = 12 ;

var a : array[1.

N] of integer ; i, count, s, max : integer ;

begin write('Массив до : ') ; for i : = 1 to n do begin a[i] : = random(19) - 8 ; write(a[i], ' ') ; if(a[i] > ; max) then max : = a[i] ; if(a[i] > ; 3) then inc(count) else if(a[i] < ; 0) then begin s : = s + a[i] ; a[i] : = i ; end ; end ; writeln ; write('Массив после : ') ; for i : = 1 to n do write(a[i], ' ') ; writeln ; writeln('1) Кол - во эл.

В массиве, значения которых > ; 3 : ', count) ; writeln('2) Сумма всех отрицательных эл.

Массива : ', s) ; writeln('3) Макс.

Элемент : ', max) ;

end.

Pigalevacat 11 февр. 2020 г., 21:12:00 | 5 - 9 классы

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :А) выведите на экран количество и индексы отрицательных элементов массива?

Массив из 40 случайных чисел, каждое из которых находится в диапазоне от - 30 до 30 :

А) выведите на экран количество и индексы отрицательных элементов массива.

Б) выведите на экран количество, индексы и значения элементов массива, кратных шести.

Дополнительно :

Выведите на экран максимальный элемент массива и его индекс.

Выведите на экран количество элементов массива, равных 7.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Lenagosa 1 мая 2020 г., 08:00:24 | 5 - 9 классы

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных?

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.

Паскаль.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Lenor35 9 февр. 2020 г., 00:16:55 | 5 - 9 классы

Задан числовой массив, состоящий из 15 элементов?

Задан числовой массив, состоящий из 15 элементов.

Подсчитать и вывести на экран количество элементов в массиве, которые меньше его первого элемента.

Никита1258 25 июн. 2020 г., 08:39:40 | 5 - 9 классы

Задан числовой массив, состоящий из 15 элементов?

Задан числовой массив, состоящий из 15 элементов.

Подсчитать и вывести на экран количество элементов в массиве, которые меньше его первого элемента.

Перед вами страница с вопросом Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.