Дан массив состоящий из 30 элементов?

Информатика | 5 - 9 классы

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Ответить на вопрос
Ответы (1)
Lion199 12 июн. 2020 г., 21:57:23

Program massiv ;

var i, max, n, j : integer ;

a : array[1.

30] of integer ;

begin

writeln ('Введитеэлементмассива') ;

for i : = 1 to 30 do

begin

write ('a[', i, '] - ') ;

readln (a[i]) ;

end ;

n : = 1 ;

max : = a[i] ;

for i : = 2 to 30 do

if max< ; a[i] then

begin

max : = a[i] ;

n : = i ;

end ;

for i : = 1 to 30 do

if a[i]< ; 0 then a[i] : = - a[i] ;

writeln ('Наибольшийэлементвмассиве ', max) ;

writeln ('Номермассива ', n) ;

writeln ('Получившийсямассив') ;

for i : = 1 to 30 do

write (a[i], ' ') ;

end.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Ulia026 12 мар. 2020 г., 22:54:59 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Срочно нужно.

Дан одномерный массив, состоящий из 10 элементов.

Вывести на экран в строчку.

Поменять местами значения от 6 - 10 элементов массива элементов массива и снова вывести на экран!

Klublena2011 27 июн. 2020 г., 01:58:52 | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

Mishincom77 6 мар. 2020 г., 08:39:19 | 10 - 11 классы

В массиве все положительные элементы увеличить в 2 раза, а все отрицательные заменить на 7?

В массиве все положительные элементы увеличить в 2 раза, а все отрицательные заменить на 7.

Вывести на экран исходный и преобразованный массивы.

Clashofclans080 30 нояб. 2020 г., 06:32:46 | 10 - 11 классы

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке?

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке.

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Ellinka21 21 мар. 2020 г., 23:25:03 | 10 - 11 классы

Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все отрицательные элементы этого массива замените на 1, а положительные ум?

Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все отрицательные элементы этого массива замените на 1, а положительные умножьте на максимальный элемент.

Марианна20045 14 нояб. 2020 г., 08:24:03 | 5 - 9 классы

Массив А состоящий из 15 элементов заполняется с клавиатуры?

Массив А состоящий из 15 элементов заполняется с клавиатуры.

Проверить есть ли в данном массиве элементы равные заданному числу b?

Вывести на экран порядковый номер таких элементов.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

Вопрос Дан массив состоящий из 30 элементов?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.