Создать одномерный массив, содержащий целые числа?

Информатика | 10 - 11 классы

Создать одномерный массив, содержащий целые числа.

Элементы массива вводятся с клавиатуры.

Найти номера всех элементов больше 5 (вывести их на экран), если таких нет, то сообщить об этом.

Ответить на вопрос
Ответы (1)
Gahhha2351 8 дек. 2020 г., 16:46:19

Const N = 5 ;

var a : array [1.

N] of integer ; flag : boolean ;

begin flag : = False ; for var i : = 1 to N do begin readln(a[i]) ; if a[i] > ; 5 then begin writeln(a[i], i : 3) ; flag : = True ; end ; end ; if not flag then writeln('Элементов больше 5 нет') ;

end.

Dzugaevzhora51 28 июн. 2020 г., 11:26:34 | 10 - 11 классы

Создать массив целых чисел, найти сумму четных элементов массива, результат вывести на экран?

Создать массив целых чисел, найти сумму четных элементов массива, результат вывести на экран.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Lera5762 22 дек. 2020 г., 07:31:29 | 5 - 9 классы

Заполнить массив размером 10 элементов целыми числами , вводимыми с клавиатуры ?

Заполнить массив размером 10 элементов целыми числами , вводимыми с клавиатуры .

Вывести на экран элементы массива и из произведения.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Zabello98 17 нояб. 2020 г., 02:59:16 | 10 - 11 классы

Дан одномерный массив состоящий из 30 элементов целого типа?

Дан одномерный массив состоящий из 30 элементов целого типа.

Найти произведение элементов массива, больше некоторого Х (вводится пользователем с клавиатуры) вывести результат на экран.

Нарисовать блок схему.

Дашуньяяя 4 дек. 2020 г., 08:21:00 | 10 - 11 классы

Найти максимальный элемент одномерного массива, содержащего А) 10 элементов ; Б) n элементов (число элементов массива вводится с клавиатуры) (в Qbasic)?

Найти максимальный элемент одномерного массива, содержащего А) 10 элементов ; Б) n элементов (число элементов массива вводится с клавиатуры) (в Qbasic).

Artem1918 1 янв. 2020 г., 05:23:47 | 10 - 11 классы

Создать два одномерных массива, состоящих из целых чисел?

Создать два одномерных массива, состоящих из целых чисел.

Элементы массива вводятся с клавиатуры.

В первом массиве найти номер первого нечетного элемента массива.

Во втором массиве найти первый четный элемент массива.

Решить на Pascal ABC (При решении задач обязательно использовать одномерные массивы и процедуры или функции работы с одномерными массивами.

).

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Марианна20045 14 нояб. 2020 г., 08:24:03 | 5 - 9 классы

Массив А состоящий из 15 элементов заполняется с клавиатуры?

Массив А состоящий из 15 элементов заполняется с клавиатуры.

Проверить есть ли в данном массиве элементы равные заданному числу b?

Вывести на экран порядковый номер таких элементов.

Appland4569 19 нояб. 2020 г., 15:04:46 | 5 - 9 классы

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ1?

3 ЗАДАЧИ НА ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ ЗА 30 БАЛЛОВ

1.

Задан массив А, состоящий из n чисел.

Найти среднее арифметическое его элементов.

Элементы вводятся с клавиатуры.

2. Найти сумму элементов массива с четными номерами, содержащего N элементов.

Элементы вводятся с клавиатуры.

3. Дан одномерный массив, значения элементов которого вводятся с клавиатуры.

Выяснить, каких элементов больше - положительных или отрицательных и насколько.

На экран вывести исходный массив и полученный результат.

На странице вопроса Создать одномерный массив, содержащий целые числа? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.