Ребята помогите?

Информатика | 5 - 9 классы

Ребята помогите!

Решать пыталась, но прога выводит ошибки!

Найти все четырехзначные натуральные числа, у которых сумма крайних цифр равна сумме сред - них цифр, а само число делится на число А!

Ответить на вопрос
Ответы (1)
Ivanovaolgasp 11 мая 2020 г., 04:37:08

Program Task1 ;

var

a, b, c, d, i : integer ;

begin

for i : = 1000 to 9999 do

begin

a : = i mod 10 ;

b : = i div 10 mod 10 ;

c : = i div 100 mod 10 ;

d : = i div 1000 mod 10 ; if (a + d = b + c ) then writeln(i) ;

end ;

end.

Карамелька8653 25 апр. 2020 г., 02:58:21 | 10 - 11 классы

Паскаль?

Паскаль.

Найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B.

Nurazaya 28 июл. 2020 г., 12:06:52 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти сумму квадратов второй и третьей цифры.

Valelelentinaa 31 мая 2020 г., 23:32:48 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти : сумму его цифр.

Написать программу на Pascal'е.

Вел2013 29 февр. 2020 г., 03:11:55 | 5 - 9 классы

Найти сумму цифр четырехзначного числа через цикл с постусловием?

Найти сумму цифр четырехзначного числа через цикл с постусловием.

Neka200 9 авг. 2020 г., 08:35:35 | 10 - 11 классы

Дано натуральное четырехзначное число n?

Дано натуральное четырехзначное число n.

Найти сумму его цифр.

Irakorshunova 3 окт. 2020 г., 14:22:46 | 5 - 9 классы

Найти сумму цифр четырехзначного числа в паскалях?

Найти сумму цифр четырехзначного числа в паскалях.

Nshaposhnik 29 мар. 2020 г., 18:01:36 | 5 - 9 классы

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой?

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой.

Alikaalika 27 авг. 2020 г., 23:16:26 | 10 - 11 классы

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)?

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры).

Olegtreys 6 сент. 2020 г., 08:03:55 | 10 - 11 классы

Среди двузначных чисел найти те, которые делятся на число q, а сумма тех цифр равна n ( 0?

Среди двузначных чисел найти те, которые делятся на число q, а сумма тех цифр равна n ( 0.

Swetas1987 14 окт. 2020 г., 00:43:43 | 5 - 9 классы

Среди всех трезначных чисел найти числа для которых верно утверждение : сумма кубов цифр этого числа равна самому числу?

Среди всех трезначных чисел найти числа для которых верно утверждение : сумма кубов цифр этого числа равна самому числу.

Составить Паскаль программу.

На этой странице сайта размещен вопрос Ребята помогите? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.