Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)?

Информатика | 10 - 11 классы

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры).

Ответить на вопрос
Ответы (1)
Kskah 27 авг. 2020 г., 23:16:28

Var

a, b, i, s : integer ;

readln(a) ;

readln(b) ;

for i = 100 to 999 do

begin

if (i mod 10) + (i div 100) + ((i mod 100) div 10) = a then

begin

if i mod b = 0 then

writeln(i) ;

end ;

end ;

end.

Карамелька8653 25 апр. 2020 г., 02:58:21 | 10 - 11 классы

Паскаль?

Паскаль.

Найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B.

Avs19082005iis 27 янв. 2020 г., 19:17:19 | 10 - 11 классы

1. С клавиатуры вводится число от 100 до 9999?

1. С клавиатуры вводится число от 100 до 9999.

Если число трехзначное, то найти произведение его цифр.

Если четырехзначное , то найти сумму этих цифр.

2. Определить, состоит, ли двузначное число, введенное с клавиатуры из одинаковых цифр.

Dinarka007 7 июл. 2020 г., 16:17:11 | 5 - 9 классы

С клавиатуры вводится натуральное число N?

С клавиатуры вводится натуральное число N.

Найдите и выведите самую большую цифру этого числа.

H1ghonline 10 февр. 2020 г., 04:28:55 | 5 - 9 классы

Составте программу , вычисления суммы цифр трёхзначного числа а?

Составте программу , вычисления суммы цифр трёхзначного числа а.

Значение а введите с клавиатуры Пример ввода : 375 Пример вывода : Сумма цифр числа 375 равна 15 2) Составте программу , которая получает 'перевёртыш' трёхзначного числа а.

Значение а введите с клавиатуры Пример ввода : 375 Пример вывода : 573.

Zoya22 10 февр. 2020 г., 13:54:03 | 5 - 9 классы

С клавиатуры вводится натуральное число n?

С клавиатуры вводится натуральное число n.

Найдите и выведите самую большую цифру этого числа.

Supergoodgirl93 9 июл. 2020 г., 23:31:58 | 5 - 9 классы

Составьте программу решения следующей задачи : С клавиатуры вводится двузначное число a?

Составьте программу решения следующей задачи : С клавиатуры вводится двузначное число a.

Найти сумму его цифр.

ЕкАтЕрИнА01 22 авг. 2020 г., 08:19:51 | 5 - 9 классы

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа?

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа.

(Dev C + + ).

Лёликет 15 дек. 2020 г., 13:58:06 | 10 - 11 классы

1) С клавиатуры вводится трёхзначное число?

1) С клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Vavdhksb 6 янв. 2020 г., 20:50:15 | 5 - 9 классы

С клавиатуры вводится четырехзначное число?

С клавиатуры вводится четырехзначное число.

Необходимо подсчитать сумму цифр этого числа.

Dnlg 5 июл. 2020 г., 05:02:40 | 5 - 9 классы

Очень нужна помощь ?

Очень нужна помощь !

С клавиатуры вводятся трёхзначные числа до тех пор, пока первая цифра не станет равна третьей.

Вывести на экран только те числа, где сумма цифр меньше десяти.

Паскаль abc.

Если вам необходимо получить ответ на вопрос Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.