Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой?

Информатика | 5 - 9 классы

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой.

Ответить на вопрос
Ответы (1)
Eleonorabaturina 29 мар. 2020 г., 18:01:38

Program asdf ;

var a, i.

B : integer ;

s : string ;

begin

readln(a) ;

s : = inttostr(a) ;

a : = length(s) ;

b : = 0 ;

for i : = 1 to a do

b : = b + s[i] ;

writeln(b) ;

if s[1] = s[a] then writeln('равны') else writeln('неравны') ;

end.

Neka200 9 авг. 2020 г., 08:35:35 | 10 - 11 классы

Дано натуральное четырехзначное число n?

Дано натуральное четырехзначное число n.

Найти сумму его цифр.

28071997 14 февр. 2020 г., 08:49:37 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Верно ли, что сумма его цифр больше 10?

Paskal.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Drashchiker 21 февр. 2020 г., 23:43:56 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найти сумму первой и последней цифры этого числа.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Dggdvcvv 3 июл. 2020 г., 00:27:57 | 5 - 9 классы

Помогите по паскалю?

Помогите по паскалю!

! Даны два целых числа.

Верно ли, что они заканчиваются на одну и ту же цифру?

Bentlii 21 нояб. 2020 г., 04:16:15 | 5 - 9 классы

Даны два натуральных числа?

Даны два натуральных числа.

Выяснить в каком из них сумма цифр больше.

(Определить функцию для расчета суммы цифр натурального числа).

Vipaybashev1 16 окт. 2020 г., 18:36:21 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Определить : a) Количество цифр в этом числе ; б)Сумму его цифр ; в)Первую цифру числа n ;

121redto 31 дек. 2020 г., 03:21:42 | 5 - 9 классы

Дано натуральному число?

Дано натуральному число.

Верно ли, что сумма его цифр не меньше 10?

Skalok 12 дек. 2020 г., 07:17:43 | 10 - 11 классы

Составить программу, прошу) Дано натуральное число, верно ли что оно начинается и заканчивается одной и той же цифрой?

Составить программу, прошу) Дано натуральное число, верно ли что оно начинается и заканчивается одной и той же цифрой.

На этой странице вы найдете ответ на вопрос Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.