Найти сумму цифр четырехзначного числа через цикл с постусловием?

Информатика | 5 - 9 классы

Найти сумму цифр четырехзначного числа через цикл с постусловием.

Ответить на вопрос
Ответы (1)
E5rtyh56y4wf 29 февр. 2020 г., 03:11:58

Var a, s : integer ;

begin

readln (a) ;

repeat

s : = s + a mod 10 ;

a : = a div 10 ;

until a = 0 ;

writeln (s) ;

end.

Nurazaya 28 июл. 2020 г., 12:06:52 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти сумму квадратов второй и третьей цифры.

Olgas2002popkov 18 апр. 2020 г., 11:02:21 | 5 - 9 классы

Чем отличается цикл с предусловием от цикла с постусловием?

Чем отличается цикл с предусловием от цикла с постусловием?

Сашка16 13 дек. 2020 г., 22:53:20 | 5 - 9 классы

Четырехзначное число, у которого первая цифра равно второй а третья четвертой, является квадратом двузначного числа?

Четырехзначное число, у которого первая цифра равно второй а третья четвертой, является квадратом двузначного числа.

Найти эти числа.

(паскаль, циклы).

Valelelentinaa 31 мая 2020 г., 23:32:48 | 10 - 11 классы

Дано четырехзначное число?

Дано четырехзначное число.

Найти : сумму его цифр.

Написать программу на Pascal'е.

Svrusyaev163 20 апр. 2020 г., 15:02:56 | 5 - 9 классы

Напечатайте в столбик нечетные числа от 3 до 25 через цикл с постусловием?

Напечатайте в столбик нечетные числа от 3 до 25 через цикл с постусловием.

Плз скорее.

Neka200 9 авг. 2020 г., 08:35:35 | 10 - 11 классы

Дано натуральное четырехзначное число n?

Дано натуральное четырехзначное число n.

Найти сумму его цифр.

Irakorshunova 3 окт. 2020 г., 14:22:46 | 5 - 9 классы

Найти сумму цифр четырехзначного числа в паскалях?

Найти сумму цифр четырехзначного числа в паскалях.

Zoya1Kononchuk 17 июн. 2020 г., 01:10:45 | 10 - 11 классы

Можно ли цикл с параметром переделать в цикл с предусловием или постусловием?

Можно ли цикл с параметром переделать в цикл с предусловием или постусловием.

Настя123999 15 мар. 2020 г., 18:41:35 | 10 - 11 классы

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием»?

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием».

Найти сумму и произведение первых n натуральных чисел.

Vavdhksb 6 янв. 2020 г., 20:50:15 | 5 - 9 классы

С клавиатуры вводится четырехзначное число?

С клавиатуры вводится четырехзначное число.

Необходимо подсчитать сумму цифр этого числа.

На этой странице находится вопрос Найти сумму цифр четырехзначного числа через цикл с постусловием?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.