Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?

Информатика | 10 - 11 классы

Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?

Ответить на вопрос
Ответы (1)
Ялюблю1234 5 сент. 2020 г., 01:26:11

Var s : string ;

i, n, max : byte ;

begin

n : = 0 ; i : = 1 ; max : = 0 ;

write('Введите s - > ; ') ; readln(s) ;

while i< ; = length(s) do begin

if (i = 1) or (s[i] = ' ') then begin

if i < ; > ; 1 then inc(i) ;

if (i< ; = length(s))and((s[i] = 'a') or (s[i] = 'A')) then

while i< ; = length(s) do

if s[i]< ; > ; ' ' then begin

inc(n) ;

inc(i) ;

end else break ;

end ;

inc(i) ;

if max< ; n then max : = n ;

n : = 0 ;

end ;

write('Длина самаго длинного слова на букву A = ', max) ;

end.

Hazeevar79 20 дек. 2020 г., 12:41:51 | 10 - 11 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

С новой строки вводится буква.

Составьте программу подсчета количества заданных букв в заданной строке.

Определить, является ли длина введенного слова числом, кратным трем.

Определить, заканчивается ли введенное слово гласной буквой.

Nfd 1 июн. 2020 г., 18:38:57 | 10 - 11 классы

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква?

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква.

Подсчитать, сколько слов начинается с указанной буквы.

Ololoshe4kaaa 15 мая 2020 г., 22:28:21 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Найти количество слов начинающихся на букву а .

Через паскаль пожалуйста ничего в нем не соображаю а иветешник задолбал.

Кицюня095 23 янв. 2020 г., 07:00:42 | 5 - 9 классы

Дана строка?

Дана строка.

Подсчитать количество слов , начинающихся с буквы Б.

Temich1999 7 окт. 2020 г., 13:57:55 | 10 - 11 классы

Составить программу, которая считает количество букв "а" в заданном слове?

Составить программу, которая считает количество букв "а" в заданном слове.

В паскаль.

Sportgirl 20 дек. 2020 г., 02:01:38 | 5 - 9 классы

Дана строка ?

Дана строка .

Написать программу для вывода на экран первой буквы строки.

Срочно!

(паскаль).

Gusev2202200 25 мая 2020 г., 06:58:26 | 5 - 9 классы

Составить программу, которая считает количество букв "а" в заданном слове (Секретные материалы)?

Составить программу, которая считает количество букв "а" в заданном слове (Секретные материалы).

В паскаль.

Таисия31 14 окт. 2020 г., 01:06:58 | 10 - 11 классы

Напишите программу, подсчитывающую количество букв во введенной строке (слове)?

Напишите программу, подсчитывающую количество букв во введенной строке (слове).

Sesnation 19 авг. 2020 г., 09:04:03 | 5 - 9 классы

Дано предложение - строка?

Дано предложение - строка.

Подсчитать количество слов, начинающихся с буквы 'а' написать программу на паскале.

Sanek05121983r 13 июн. 2020 г., 14:49:04 | 10 - 11 классы

Подсчитайте количество гласных латинских букв в строке?

Подсчитайте количество гласных латинских букв в строке.

(ПАСКАЛЬ).

Вы открыли страницу вопроса Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву А , и выводящуюю количество букв в нём?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.