Заменить значения всех отрицательных элементов матрицы на нулевые с помощью языка С?

Информатика | студенческий

Заменить значения всех отрицательных элементов матрицы на нулевые с помощью языка С.

КАК? ПОМОГИТЕ ПОЖАЛУЙСТА.

Ответить на вопрос
Ответы (1)
555335z 13 мая 2022 г., 15:42:06

#include

#include

#include

const unsigned int n = 5 ;

const unsigned int m = 6 ;

int main()

{ srand(time(NULL)) ; int i, j ; int a[n][m] ; printf(" \ nSource : \ n") ; for (i = 0 ; i < n ; i + + ) { for (j = 0 ; j < m ; j + + ) { a[i][j] = rand() % 201 - 100 ; printf("%d \ t", a[i][j]) ; } printf(" \ n") ; } printf(" \ nResult : \ n") ; for ( i = 0 ; i < n ; i + + ) { for (j = 0 ; j < m ; j + + ) { if (a[i][j] < 0) a[i][j] = 0 ; printf("%d \ t", a[i][j]) ; } printf(" \ n") ; } getchar() ;

}.

Tplotitsin 10 янв. 2022 г., 22:54:45 | 10 - 11 классы

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива?

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива.

Tane4ka211192 11 мар. 2022 г., 11:01:57 | 10 - 11 классы

Написать программу на языке С + + :Сформировать случайным образом целочисленную матрицу N * N?

Написать программу на языке С + + :

Сформировать случайным образом целочисленную матрицу N * N.

Сформировать два одномерных массива А и В : в массив А записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив В - элементы, лежащие на побочной диагонали и ниже неё.

Vashukariana 1 янв. 2022 г., 14:01:08 | 10 - 11 классы

Помогите решить в Си?

Помогите решить в Си!

Дана матрица А состоящая из m строк n столбцов найти среднее арифметическое трех элементов матрицы каждый из которых больше находящегося с ним в одной строчке элемента главной диагонали и сумму элементов главной диагонали.

Maryana11Ro 7 апр. 2022 г., 05:47:03 | 10 - 11 классы

Составить блок - схему :Заменить все отрицательные элементы массива на ноль?

Составить блок - схему :

Заменить все отрицательные элементы массива на ноль.

Ignor73 2 янв. 2022 г., 06:40:05 | 10 - 11 классы

Дан массив вставить число k после первого отрицательного элемента?

Дан массив вставить число k после первого отрицательного элемента.

Паскаль.

Напишите, пожалуйста.

Vladimirkarpov1 7 янв. 2022 г., 10:40:05 | студенческий

Дана матрица размером 7Х7 элементов, случайным образом заполненная?

Дана матрица размером 7Х7 элементов, случайным образом заполненная.

Просчитать сумму

элементов вспомогательной диагонали ( i = n - j + 1 ).

Определить количество элементов > сумма / 3.

Елена10903 20 мая 2022 г., 00:50:20 | 10 - 11 классы

Дано матрицу В размером 5х6?

Дано матрицу В размером 5х6.

Разделить элемент каждой строки на элемент, который находится в 3 столбце этой строки.

(Язык програмирования С или С + + ).

Двоечниг 16 апр. 2022 г., 12:44:18 | 10 - 11 классы

Дана матрица действительных чисел A размером 6х7?

Дана матрица действительных чисел A размером 6х7.

Сформировать массив R1, …, R7, каждый элемент которого равен

среднему арифметическому значению элементов

соответствующего столбца матрицы A : написать программу С + , помогите пожалуйста.

Марина1806 19 июн. 2022 г., 02:37:13 | 5 - 9 классы

C + +найти наибольший отрицательный элемент массива n(x) и его порядковый номерПомогите, пожалуйста?

C + +

найти наибольший отрицательный элемент массива n(x) и его порядковый номер

Помогите, пожалуйста!

12319201 20 июн. 2022 г., 11:18:35 | студенческий

Помогите пожалуйста ?

Помогите пожалуйста .

В паскале , Заменить элементы с К1 - й по К2 - й на обратные.

На этой странице сайта размещен вопрос Заменить значения всех отрицательных элементов матрицы на нулевые с помощью языка С? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников студенческий. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.