Помогите решить в Си?

Информатика | 10 - 11 классы

Помогите решить в Си!

Дана матрица А состоящая из m строк n столбцов найти среднее арифметическое трех элементов матрицы каждый из которых больше находящегося с ним в одной строчке элемента главной диагонали и сумму элементов главной диагонали.

Ответить на вопрос
Ответы (1)
Himik423 1 янв. 2022 г., 14:01:12

#include

#define N .

#define M .

#define _MIN(a, b) ((a) < (b) ?

(a) : (b))

.

Int A[N][M], sumOfDiagonal = 0, sumOfEl = 0, numOfEl = 0, diagonalEl, border, i, j ;

.

Border = _MIN(N, M) ;

for (i = 0 ; i < border ; i + + ) sumOfDiagonal + = A[i][i] ;

printf("Sum of the main diagonal elements = %i \ n", sumOfDiagonal) ;

for (i = 0 ; i < border ; i + + )

{ diagonalEl = A[i][i] ; for (j = 0 ; j < M ; j + + ) if (A[i][j] > diagonalEl) sumOfEl + = A[i][j], numOfEl + + ;

}

printf("The arithmetic mean of the elements = %f \ n", (double)sumOfEl / numOfEl) ;

.

МАША14961 4 февр. 2022 г., 21:56:09 | 10 - 11 классы

Дан массив, посчитать среднее арифметическое элементов, стоящих на четных местах?

Дан массив, посчитать среднее арифметическое элементов, стоящих на четных местах.

Сформировать их этих элементов новый массив.

Tane4ka211192 11 мар. 2022 г., 11:01:57 | 10 - 11 классы

Написать программу на языке С + + :Сформировать случайным образом целочисленную матрицу N * N?

Написать программу на языке С + + :

Сформировать случайным образом целочисленную матрицу N * N.

Сформировать два одномерных массива А и В : в массив А записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив В - элементы, лежащие на побочной диагонали и ниже неё.

Not79371 8 мар. 2022 г., 04:32:07 | 10 - 11 классы

1) Задано натуральное число N?

1) Задано натуральное число N.

Составить программу для вычисления S = 1 + 3 + 5 + … + N

2) Подсчитать количество четных элементов в каждом столбце матрицы размером МхN.

Rusya545 21 мар. 2022 г., 00:09:50 | 10 - 11 классы

11 класс двумерные массивы В ПАСКАЛЕзаполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран1?

11 класс двумерные массивы В ПАСКАЛЕ

заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран

1.

Удвоить все элементы и вывести на экран

2.

Найти максимальный и минимальный элемент ввода и вывести их на экран

3.

Вывести на экран строку сумма элементов которой максимальна.

Annaprav2004 1 февр. 2022 г., 18:51:27 | 10 - 11 классы

Даны 2 файла1)Даны числа, вывести максимальный элемент?

Даны 2 файла

1)Даны числа, вывести максимальный элемент.

2) Даны числа, найти среднее арифметическое .

Python

Помогите, пожалуйста).

Vladimirkarpov1 7 янв. 2022 г., 10:40:05 | студенческий

Дана матрица размером 7Х7 элементов, случайным образом заполненная?

Дана матрица размером 7Х7 элементов, случайным образом заполненная.

Просчитать сумму

элементов вспомогательной диагонали ( i = n - j + 1 ).

Определить количество элементов > сумма / 3.

Елена10903 20 мая 2022 г., 00:50:20 | 10 - 11 классы

Дано матрицу В размером 5х6?

Дано матрицу В размером 5х6.

Разделить элемент каждой строки на элемент, который находится в 3 столбце этой строки.

(Язык програмирования С или С + + ).

Двоечниг 16 апр. 2022 г., 12:44:18 | 10 - 11 классы

Дана матрица действительных чисел A размером 6х7?

Дана матрица действительных чисел A размером 6х7.

Сформировать массив R1, …, R7, каждый элемент которого равен

среднему арифметическому значению элементов

соответствующего столбца матрицы A : написать программу С + , помогите пожалуйста.

Deeen 13 мая 2022 г., 15:42:02 | студенческий

Заменить значения всех отрицательных элементов матрицы на нулевые с помощью языка С?

Заменить значения всех отрицательных элементов матрицы на нулевые с помощью языка С.

КАК? ПОМОГИТЕ ПОЖАЛУЙСТА.

7vlad2003 14 мар. 2022 г., 04:43:21 | 5 - 9 классы

Даю 25 баллов?

Даю 25 баллов!

Дан массив из 20 вещественных чисел.

Найти среднее арифметическое чисел элементов массива и заменить на него максимум и минимум элементов массива стоящие на местах кратных 5.

Перед вами страница с вопросом Помогите решить в Си?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.