Дана матрица размером 7Х7 элементов, случайным образом заполненная?

Информатика | студенческий

Дана матрица размером 7Х7 элементов, случайным образом заполненная.

Просчитать сумму

элементов вспомогательной диагонали ( i = n - j + 1 ).

Определить количество элементов > сумма / 3.

Ответить на вопрос
Ответы (1)
Figoro744 7 янв. 2022 г., 10:40:08

Const n = 7 ;

begin var a : = MatrRandom(n, n, - 20, 20) ; a.

Println(4) ; var s : = 0 ; for var i : = 0 to a.

RowCount - 1 do s : = s + a[i, n - i - 1] ; Writeln('s = ', s) ; var k : = a.

ElementsByRow.

Where(x - >x>s / 3).

Count ; writeln('k = ', k) ;

end.

Пример : - 4 - 14 1 4 1 8 20 - 10 - 19 5 - 19 - 15 0 2 - 11 - 13 0 - 15 - 6 13 - 11 - 16 5 - 18 2 19 - 8 - 11 10 - 2 19 - 10 20 8 1 9 - 12 2 12 4 0 7 5 6 1 9 - 5 4 - 11

s = 28

k = 7.

Arin4eg 29 янв. 2022 г., 16:08:12 | 5 - 9 классы

ПОМОГИТЕ РЕШИТЬ В ПАСКАЛЕ?

ПОМОГИТЕ РЕШИТЬ В ПАСКАЛЕ!

Даны 2 массива сформированных случайным образом.

Составить программу которая находит сумму минимальных элементов массива

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО.

Tplotitsin 10 янв. 2022 г., 22:54:45 | 10 - 11 классы

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива?

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива.

Tane4ka211192 11 мар. 2022 г., 11:01:57 | 10 - 11 классы

Написать программу на языке С + + :Сформировать случайным образом целочисленную матрицу N * N?

Написать программу на языке С + + :

Сформировать случайным образом целочисленную матрицу N * N.

Сформировать два одномерных массива А и В : в массив А записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив В - элементы, лежащие на побочной диагонали и ниже неё.

Vashukariana 1 янв. 2022 г., 14:01:08 | 10 - 11 классы

Помогите решить в Си?

Помогите решить в Си!

Дана матрица А состоящая из m строк n столбцов найти среднее арифметическое трех элементов матрицы каждый из которых больше находящегося с ним в одной строчке элемента главной диагонали и сумму элементов главной диагонали.

Rusya545 21 мар. 2022 г., 00:09:50 | 10 - 11 классы

11 класс двумерные массивы В ПАСКАЛЕзаполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран1?

11 класс двумерные массивы В ПАСКАЛЕ

заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран

1.

Удвоить все элементы и вывести на экран

2.

Найти максимальный и минимальный элемент ввода и вывести их на экран

3.

Вывести на экран строку сумма элементов которой максимальна.

Наталья5555 28 февр. 2022 г., 03:13:50 | 1 - 4 классы

Javascript вычислить сумму элементов массива, порядковые номера которых совпадают со значениями этого элемента?

Javascript вычислить сумму элементов массива, порядковые номера которых совпадают со значениями этого элемента.

Nastya987456 21 янв. 2022 г., 20:18:21 | 10 - 11 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется определить, превосходит ли 100 сумма элементов, которые больше 20.

СнежанаСноу 16 февр. 2022 г., 12:53:17 | 5 - 9 классы

В массиве случайных чисел посчитать количество положительных элементов?

В массиве случайных чисел посчитать количество положительных элементов.

Елена10903 20 мая 2022 г., 00:50:20 | 10 - 11 классы

Дано матрицу В размером 5х6?

Дано матрицу В размером 5х6.

Разделить элемент каждой строки на элемент, который находится в 3 столбце этой строки.

(Язык програмирования С или С + + ).

Двоечниг 16 апр. 2022 г., 12:44:18 | 10 - 11 классы

Дана матрица действительных чисел A размером 6х7?

Дана матрица действительных чисел A размером 6х7.

Сформировать массив R1, …, R7, каждый элемент которого равен

среднему арифметическому значению элементов

соответствующего столбца матрицы A : написать программу С + , помогите пожалуйста.

На этой странице сайта вы найдете ответы на вопрос Дана матрица размером 7Х7 элементов, случайным образом заполненная?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников студенческий. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.