Дан массив вставить число k после первого отрицательного элемента?

Информатика | 10 - 11 классы

Дан массив вставить число k после первого отрицательного элемента.

Паскаль.

Напишите, пожалуйста.

Ответить на вопрос
Ответы (1)
Spike3 2 янв. 2022 г., 06:40:08

Const n = 10 ;

var a : array[1.

N + 1] of integer ;

k, i, j : integer ;

begin

Randomize ;

writeln('Исходный массив') ;

for i : = 1 to n do begin

a[i] : = random(51) - 10 ;

write(a[i], ' ') ;

end ;

writeln ;

write('k = ') ;

readln(k) ;

j : = 1 ;

while (j = 0) do j : = j + 1 ;

if a[j]> = 0 then writeln('Отрицательных элементов нет')

else begin

for i : = n downto j + 1 do a[i + 1] : = a[i] ;

a[j + 1] : = k ;

writeln('Измененный массив : ') ;

for i : = 1 to n + 1 do write(a[i], ' ') ;

writeln ;

end ;

end.

Пример :

Исходный массив

19 5 17 - 4 23 - 9 25 33 13 16

k = 10

Измененный массив :

19 5 17 - 4 10 23 - 9 25 33 13 16.

Sony1111111 2 янв. 2022 г., 16:10:51 | 5 - 9 классы

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент вмассиве, размерностью N, сформированном пользователем?

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент в

массиве, размерностью N, сформированном пользователем.

Задача №2 : Дан одномерный массив вещественных чисел в диапазоне от 0 до 1.

Определите сумму и среднее арифметическое его элементов.

Задача №3 : Дан целочисленный одномерный массив, сформированный случайными

числами от 0 до 50.

Подсчитайте, сколько раз встречается в этой таблице число, заданное

пользователем.

Goha12 4 янв. 2022 г., 03:35:24 | 5 - 9 классы

Записать задачи на языке Паскаль (используются циклы)1?

Записать задачи на языке Паскаль (используются циклы)

1.

Дан массив А имеющий 100 элементов.

Заполнен в интервале - 400 до 70.

Заменить числа в массиве большие К на само число К

2.

Дан массив А, имеющий 50 элементов.

Заполнен в интервале от - 100 до 10.

Посчитать количество положительных чисел.

Dasha29f 10 февр. 2022 г., 20:51:31 | 5 - 9 классы

Дано трехзначное число Х, вводимое с клавиатуры?

Дано трехзначное число Х, вводимое с клавиатуры.

Первую цифру этого числа перенесли в конец.

Вывести на экран полученное число.

( работать в паскале).

Azamat2404 3 мар. 2022 г., 12:19:17 | 1 - 4 классы

(Паскаль) Дан текстовый файл, содержащий вещественные числа (положительные и отрицательные) в произвольном порядке?

(Паскаль) Дан текстовый файл, содержащий вещественные числа (положительные и отрицательные) в произвольном порядке.

Сформируйте массив, содержащий только положительные числа из файла, и найдите наименьшее среди них.

MARINABARDYMOV 25 янв. 2022 г., 02:50:21 | 5 - 9 классы

Дан одномерный массив [ - 50 : 50], нужно вывести числа больше 7, программа на Паскаль?

Дан одномерный массив [ - 50 : 50], нужно вывести числа больше 7, программа на Паскаль.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

Dan34111 7 янв. 2022 г., 10:14:06 | студенческий

Помогите пожалуйста задание, надо код для паскали?

Помогите пожалуйста задание, надо код для паскали.

Дан одномерный массив, найти сумму всех четных элемент массива, кратных заданному числу.

Максим146464647447 6 апр. 2022 г., 04:28:08 | 10 - 11 классы

В паскаль АВСЗаполнить массив А[1?

В паскаль АВС

Заполнить массив А[1.

8] числами, вводимыми с клавиатуры.

Найти среднее арифметическое четных элементов.

Женя321 14 мар. 2022 г., 05:53:10 | 5 - 9 классы

Даны 2 числа А и В?

Даны 2 числа А и В.

Найти наибольшее и наименьшее из них и вывести на экран.

Паскаль.

Помогите пожалуйста.

AidBag 6 апр. 2022 г., 06:38:49 | 10 - 11 классы

Помогите с паскалем : описать числовой массив на 5 элементов изаполнить его присваиванием любыми числами,распечатать содержимое элементов массива?

Помогите с паскалем : описать числовой массив на 5 элементов и

заполнить его присваиванием любыми числами,

распечатать содержимое элементов массива.

На странице вопроса Дан массив вставить число k после первого отрицательного элемента? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.