Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами?

Информатика | 5 - 9 классы

Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами.

Ответить на вопрос
Ответы (1)
Olgariselan 27 янв. 2022 г., 16:01:51

Program DZ ;

var n, i, k, j, f : longint ; a : array [1.

10000] of longint ;

begin k : = 0 ; read (n) ; a[1] : = 1 ; a[2] : = 1 ; for i : = 3 to 10000 do begin if not(a[i - 1] < n) then begin break end ; a[i] : = a[i - 1] + a[i - 2] ; k : = k + 1 end ; for i : = 1 to k do begin f : = 0 ; for j : = 2 to a[i] - 1 do if a[i] mod j = 0 then f : = 1 ; if f = 0 then write (a[i], ' ') ; end ;

end.

Это для Pascal.

Лузэрок 10 янв. 2022 г., 05:26:39 | 5 - 9 классы

Вывести на экран квадраты нечетных чисел, от 1 до 9?

Вывести на экран квадраты нечетных чисел, от 1 до 9.

Sony1111111 2 янв. 2022 г., 16:10:51 | 5 - 9 классы

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент вмассиве, размерностью N, сформированном пользователем?

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент в

массиве, размерностью N, сформированном пользователем.

Задача №2 : Дан одномерный массив вещественных чисел в диапазоне от 0 до 1.

Определите сумму и среднее арифметическое его элементов.

Задача №3 : Дан целочисленный одномерный массив, сформированный случайными

числами от 0 до 50.

Подсчитайте, сколько раз встречается в этой таблице число, заданное

пользователем.

89517768990 2 янв. 2022 г., 17:20:12 | 5 - 9 классы

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N?

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N.

Простым называется натуральное число больше единицы, имеющее только два делителя : единицу и само это число.

Rusya545 21 мар. 2022 г., 00:09:50 | 10 - 11 классы

11 класс двумерные массивы В ПАСКАЛЕзаполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран1?

11 класс двумерные массивы В ПАСКАЛЕ

заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран

1.

Удвоить все элементы и вывести на экран

2.

Найти максимальный и минимальный элемент ввода и вывести их на экран

3.

Вывести на экран строку сумма элементов которой максимальна.

Севиля91 13 янв. 2022 г., 10:24:35 | 5 - 9 классы

1. Задать массив из 10 элементов с пом?

1. Задать массив из 10 элементов с пом.

Генератора случ.

Чисел из интервала (10, 30).

Увеличить каждое число в массиве три раза.

Вывести на экран оба массив(результат и исходный)

2.

Дано 2 массива из 80 элементов.

Заполнить первый с помощью генератора случ.

Чисел на интервале (50, 100) и заполнить второй массив корнями квадратными из чисел исходного массива.

Makmarika 15 февр. 2022 г., 08:19:30 | 10 - 11 классы

С массива A(10) сформировать массив В(10), отличный от исходного тем, что числа, кратные 5 удвоены?

С массива A(10) сформировать массив В(10), отличный от исходного тем, что числа, кратные 5 удвоены.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

Zhuldizbest 24 мая 2022 г., 16:37:06 | студенческий

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000]?

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000].

Вывести число элементов с наименьшим и наибольшим значениями этого массива / помогите, пожалуйста.

Ryagin 8 мая 2022 г., 13:35:52 | 5 - 9 классы

Помогите, пожалуйста : )1)Вывести на экран натуральные не четные числа от 50 до 40?

Помогите, пожалуйста : )

1)Вывести на экран натуральные не четные числа от 50 до 40.

2)Найти произведение последовательных натуральных чисел от 7 до 12.

JaneMilkYTber 14 апр. 2022 г., 05:34:57 | 5 - 9 классы

Два множества : первое все простые делители некоторого целого числа N и второе все простые делители того же числа?

Два множества : первое все простые делители некоторого целого числа N и второе все простые делители того же числа.

Вывести на экран делители которые не являются простыми.

(Паскаль).

На этой странице сайта размещен вопрос Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.