Написал прогу на С + + ?

Информатика | 5 - 9 классы

Написал прогу на С + + .

А она выдаёт ошибку.

Можете мне сказать, где ошибка?

Ответить на вопрос
Ответы (1)
Катя3903 25 апр. 2024 г., 22:46:49

1 строка : Зачем вы подключили эту библиотеку, если нигде ее не используете?

2 строка : Зачем вы подключили эту библиотеку, если нигде ее не используете?

7 строка : Если вы уж и решили инициализировать двумерный массив, то делайте это полностью.

+ нет " ; " в конце определения.

11 строка : Зачем здесь цикл, если переменная k даже нигде не используется?

Я считаю, что это лишние итерации.

18 - 19 строки : Зачем менять условие, но выполнять ту же самую операцию, что и в строке 13?

19 - 22 строки : что вы хотели сделать этим?

Наверное, чтобы привести код к виду

int main()

{

} / / < ; - - - -

Нужно удалить открывающую скобку на стр.

20. Вообще, не советую опускать операторные скобки, чтобы не нарушать читабельность кода.

YanockaKisil 25 февр. 2024 г., 05:08:26 | 5 - 9 классы

Задание №1?

Задание №1.

Напишите программу, которая находит сумму цифр чисел между k и р.

Какую ошибку вы допу - стили при выполнении задания?

Про - верьте работу операторов, расположен - ных в теле цикла, путем трассировки.

​.

Dandyd 10 мар. 2024 г., 04:48:51 | студенческий

ДАЮ 30 БАЛЛОВ?

ДАЮ 30 БАЛЛОВ!

Выдает такую ошибку, что мне надо исправить я не понимаю Fatal : Syntax error, ")" expected but "identifier D" found Program P2 ;

var a, b : integer ; d, s, p : real ;

Begin

write('введите сторону прямоугольника a = ') ;

readln(a) ;

write('введите сторону прямоугольника b = ') ;

readln(b) ; d : = sqrt(sqr(a) + sqr(b)) ;

writeln('диагональ прямоугольника = 'd) ;

s : = a * b ;

writeln('площадь прямоугольника = 's) ;

p : = 2 * (a + b) ; writeln('периметр прямоугольника = 'p) ;

end.

Квазимод 7 янв. 2024 г., 04:39:13 | 10 - 11 классы

Даю 50 баловНаписать код на python?

Даю 50 балов

Написать код на python.

SENSEY11111 23 янв. 2024 г., 18:37:43 | студенческий

Выдает такую ошибку , в чем проблема?

Выдает такую ошибку , в чем проблема?

Source.

Pas(13, 11) Fatal : Syntax error, ")" expected but "(" found

Program P1 ;

var a, b, c : integer ;

s, p : real ;

Begin

write('введите координату a = ') ; readln(a) ; write('введите координату b = ') ;

readln(b) ; write('введите координату c = ') ; readln(c) ; P : = (a + b + c) / 2 ;

writeln('периметр треугольника = ', P : 2 : 2) ;

s : = sqrt(p(p - a) * (p - b) * (p - c)) ; writeln('площадь треугольника = ', s : 2 : 2) ;

end.

NastyushaCat05 23 февр. 2024 г., 02:24:30 | 1 - 4 классы

Можете будь ласка виконати це завдання?

Можете будь ласка виконати це завдання.

​.

AnnCherevko2005 23 февр. 2024 г., 15:03:58 | 10 - 11 классы

Люди подскажите где ошибка, пожалуйста?

Люди подскажите где ошибка, пожалуйста.

Это Pascal

когда компилирую это и ввожу числа 10 и 5 ответ выходит 0.

0​

program h ;

var a : real ;

b : real ;

c : real ;

begin

a : = b + c ;

WriteLn('Введите числа, которые необходимо сложить : ') ;

readln(b) ;

readln(c) ;

Writeln('Ответ : ', a) ;

end.

Love198625 21 мар. 2024 г., 21:42:12 | 5 - 9 классы

Не могу понять ошибку?

Не могу понять ошибку.

Помогите (язык паскаль).

Djruzik 14 мар. 2024 г., 10:10:57 | 10 - 11 классы

Кто - нибудь можете мне помогать с Информатикой?

Кто - нибудь можете мне помогать с Информатикой?

ПОЖАЛУЙСТА(((.

Никнейм54 2 февр. 2024 г., 00:18:34 | 10 - 11 классы

Ребят помогите пжлстанадо для этого написать программу вычисления ​?

Ребят помогите пжлста

надо для этого написать программу вычисления ​.

Nijita100204 8 февр. 2024 г., 13:57:16 | 5 - 9 классы

Напряжениена контактах принимает значения от 0 до 5 вольт?

Напряжение

на контактах принимает значения от 0 до 5 вольт.

Сколько битов нужно

использовать для дискретизации такого сигнала, чтобы ошибка составляла не более

1%?

При дискретизации измеренное напряжение округляется до ближайшего меньшего

значения, которое точно представляется двоичным кодом.

DingoDeMango 18 янв. 2024 г., 07:05:38 | 10 - 11 классы

Нужна помощь в задания по информатике , надо написать задачи на питоне?

Нужна помощь в задания по информатике , надо написать задачи на питоне.

На этой странице находится ответ на вопрос Написал прогу на С + + ?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.