С массива A(10) сформировать массив В(10), отличный от исходного тем, что числа, кратные 5 удвоены?

Информатика | 10 - 11 классы

С массива A(10) сформировать массив В(10), отличный от исходного тем, что числа, кратные 5 удвоены.

Ответить на вопрос
Ответы (1)
Ksyushagavrilova 15 февр. 2022 г., 08:19:36

#include

template< typename int_dt >

int_dt *

transform(int_dt * arr, size_t n)

{ int_dt * new_arr = new int_dt[n] ; for (int i = 0 ; i < n ; i + + ) { new_arr[i] = arr[i] % 5 ?

Arr[i] : 2 * arr[i] ; } return new_arr ;

}

int

main(void)

{ enum { ARR_SIZE = 10 } ; int a[] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10} ; int * b = transform(a, ARR_SIZE) ; for (int i = 0 ; i < ARR_SIZE ; i + + ) { printf("%d ", b[i]) ; } delete[] b ; return 0 ;

}.

Natasha7305 14 янв. 2022 г., 18:05:39 | 10 - 11 классы

1)Ввести массив A из 25 элементов?

1)Ввести массив A из 25 элементов.

Cформировать массив B из элементов массива А, кратных трем.

2)Даны массив A и B из n элементов.

Cформировать массив C из элементов массивов А и B, чередуя элементы.

Sony1111111 2 янв. 2022 г., 16:10:51 | 5 - 9 классы

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент вмассиве, размерностью N, сформированном пользователем?

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент в

массиве, размерностью N, сформированном пользователем.

Задача №2 : Дан одномерный массив вещественных чисел в диапазоне от 0 до 1.

Определите сумму и среднее арифметическое его элементов.

Задача №3 : Дан целочисленный одномерный массив, сформированный случайными

числами от 0 до 50.

Подсчитайте, сколько раз встречается в этой таблице число, заданное

пользователем.

Ksenia2283 27 янв. 2022 г., 16:01:50 | 5 - 9 классы

Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами?

Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами.

Tane4ka211192 11 мар. 2022 г., 11:01:57 | 10 - 11 классы

Написать программу на языке С + + :Сформировать случайным образом целочисленную матрицу N * N?

Написать программу на языке С + + :

Сформировать случайным образом целочисленную матрицу N * N.

Сформировать два одномерных массива А и В : в массив А записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив В - элементы, лежащие на побочной диагонали и ниже неё.

Севиля91 13 янв. 2022 г., 10:24:35 | 5 - 9 классы

1. Задать массив из 10 элементов с пом?

1. Задать массив из 10 элементов с пом.

Генератора случ.

Чисел из интервала (10, 30).

Увеличить каждое число в массиве три раза.

Вывести на экран оба массив(результат и исходный)

2.

Дано 2 массива из 80 элементов.

Заполнить первый с помощью генератора случ.

Чисел на интервале (50, 100) и заполнить второй массив корнями квадратными из чисел исходного массива.

AlinaMarks 27 апр. 2022 г., 10:14:26 | 5 - 9 классы

Задан целочисленный массив размера N?

Задан целочисленный массив размера N.

Определить число элементов в массиве кратных 2 (написать на pascal).

Katykolomeiceva 1 апр. 2022 г., 03:07:07 | 5 - 9 классы

Массив - 10 элементов?

Массив - 10 элементов.

Задача :

Удвоить все четные элементы массива.

Все элементы с нечетным номером разделить на первый

элемент массива.

Срочно!

Завтра сдавать Дз.

Dimonichk 11 мар. 2022 г., 02:46:40 | студенческий

Помогите, пожалуйста нужен код для паскали Найти сумму всех четных элементов массива, кратных заданному числу?

Помогите, пожалуйста нужен код для паскали Найти сумму всех четных элементов массива, кратных заданному числу.

Zhuldizbest 24 мая 2022 г., 16:37:06 | студенческий

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000]?

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000].

Вывести число элементов с наименьшим и наибольшим значениями этого массива / помогите, пожалуйста.

Dan34111 7 янв. 2022 г., 10:14:06 | студенческий

Помогите пожалуйста задание, надо код для паскали?

Помогите пожалуйста задание, надо код для паскали.

Дан одномерный массив, найти сумму всех четных элемент массива, кратных заданному числу.

Вопрос С массива A(10) сформировать массив В(10), отличный от исходного тем, что числа, кратные 5 удвоены?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.