Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент вмассиве, размерностью N, сформированном пользователем?

Информатика | 5 - 9 классы

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент в

массиве, размерностью N, сформированном пользователем.

Задача №2 : Дан одномерный массив вещественных чисел в диапазоне от 0 до 1.

Определите сумму и среднее арифметическое его элементов.

Задача №3 : Дан целочисленный одномерный массив, сформированный случайными

числами от 0 до 50.

Подсчитайте, сколько раз встречается в этой таблице число, заданное

пользователем.

Ответить на вопрос
Ответы (1)
Kukutiha 2 янв. 2022 г., 16:10:56

Задачи решаются проходом по элементам массива (в цикле).

В первой задаче сравниваем каждый элемент массива с 0.

Если меньше - выводим сообщение и выходим из цикла

Во второй складываем элементы массива - сумма, а потом делим на кол - во элементов - сер.

Арифметич.

В третьей - проходим по всем элементам и сравниваем с заданным числом.

Если совпал - увеличиваем счетчик на единицу.

0809annie 28 янв. 2022 г., 04:01:38 | 5 - 9 классы

Помогите изменить массив :Дан одномерный целочисленный массив mas?

Помогите изменить массив :

Дан одномерный целочисленный массив mas.

Поменять местами два элемента массива с номерами k1 и k2, если оба этих элемента чётны.

Иначе – запросить у пользователя индекс ещё одного элемента k 3 и поменять его местами с первым элементом массива.

Вывести на экран итоговый массив в строку.

Массив :

Program pr1 ;

Var i, N, k1, k2, R : integer ; mas : array[1.

100]of integer ;

Begin Writeln ('Введите число элементов массива (N.

Ksenia2283 27 янв. 2022 г., 16:01:50 | 5 - 9 классы

Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами?

Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами.

Дарья176 17 янв. 2022 г., 22:13:03 | 5 - 9 классы

Сформировать одномерный массив из 15 целых числе, элементы которого выбрасываются случайным образом из отрезка от - 3 до 6?

Сформировать одномерный массив из 15 целых числе, элементы которого выбрасываются случайным образом из отрезка от - 3 до 6.

Подсчитать количество нечетных чисел.

Оформить дружественный интерфейс.

МАША14961 4 февр. 2022 г., 21:56:09 | 10 - 11 классы

Дан массив, посчитать среднее арифметическое элементов, стоящих на четных местах?

Дан массив, посчитать среднее арифметическое элементов, стоящих на четных местах.

Сформировать их этих элементов новый массив.

Макс12908478985 26 янв. 2022 г., 16:34:04 | 10 - 11 классы

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива?

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива.

Начертить алгоритм и написать программу.

Tane4ka211192 11 мар. 2022 г., 11:01:57 | 10 - 11 классы

Написать программу на языке С + + :Сформировать случайным образом целочисленную матрицу N * N?

Написать программу на языке С + + :

Сформировать случайным образом целочисленную матрицу N * N.

Сформировать два одномерных массива А и В : в массив А записать элементы матрицы, расположенные на главной диагонали и ниже неё, в массив В - элементы, лежащие на побочной диагонали и ниже неё.

SemenZakharov11 18 апр. 2022 г., 00:51:35 | 10 - 11 классы

1) Ввести одномерный массив А из 12 элементов?

1) Ввести одномерный массив А из 12 элементов.

Определите в нём среднее геометрическое квадратов нечетных чисел.

2) Ввести одномерный массив А из N элементов.

Каждый элемент, чей модуль больше 10, обнулить.

Массив вывести до и после преобразования.

Zhuldizbest 24 мая 2022 г., 16:37:06 | студенческий

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000]?

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000].

Вывести число элементов с наименьшим и наибольшим значениями этого массива / помогите, пожалуйста.

Dan34111 7 янв. 2022 г., 10:14:06 | студенческий

Помогите пожалуйста задание, надо код для паскали?

Помогите пожалуйста задание, надо код для паскали.

Дан одномерный массив, найти сумму всех четных элемент массива, кратных заданному числу.

Котик428 26 мар. 2022 г., 21:03:39 | 5 - 9 классы

Задан целочисленный одномерный массив с именем А, размером N с помощью датчика случайных чисел на промежутке (0 ; 10)?

Задан целочисленный одномерный массив с именем А, размером N с помощью датчика случайных чисел на промежутке (0 ; 10).

1. Найти минимальные элементы в массиве.

2. Найти порядковый номер этого элемента.

Вопрос Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент вмассиве, размерностью N, сформированном пользователем?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.