Два множества : первое все простые делители некоторого целого числа N и второе все простые делители того же числа?

Информатика | 5 - 9 классы

Два множества : первое все простые делители некоторого целого числа N и второе все простые делители того же числа.

Вывести на экран делители которые не являются простыми.

(Паскаль).

Ответить на вопрос
Ответы (1)
Nurusheva2002 14 апр. 2022 г., 05:34:59

Замечание : в старых версиях паскаля вместо integer нужно использовать byte.

Var n, i : integer ;

s1, s2 : set of integer ;

function prost(n : integer) : boolean ;

var j, m : integer ;

begin

m : = 0 ;

for j : = 2 to trunc(sqrt(n)) do

if n mod j = 0 then inc(m) ;

prost : = m = 0 ;

end ;

begin

readln(n) ;

s1 : = [1] ; s2 : = [] ;

for i : = 2 to n do

if n mod i = 0 then begin s1 : = s1 + [i] ; if prost(i) then s2 : = s2 + [i] ; end ;

writeln('Все делители : ') ;

for i : = 1 to n do

if i in s1 then write(i, ' ') ;

writeln ;

writeln('Все простые делители : ') ;

for i : = 1 to n do

if i in s2 then write(i, ' ') ;

writeln ;

writeln('Делители, которые не являются простыми : ') ;

for i : = 1 to n do

if i in (s1 - s2) then write(i, ' ') ;

end.

Пример :

340

Все делители :

1 2 4 5 10 17 20 34 68 85 170 340

Все простые делители :

2 5 17

Делители, которые не являются простыми :

1 4 10 20 34 68 85 170 340.

Ksenia2283 27 янв. 2022 г., 16:01:50 | 5 - 9 классы

Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами?

Сформировать массив из чисел Фибоначчи небольших заданного натурального N, вывести на экран значение электронного массива являющимся простыми числами.

89517768990 2 янв. 2022 г., 17:20:12 | 5 - 9 классы

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N?

Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N.

Простым называется натуральное число больше единицы, имеющее только два делителя : единицу и само это число.

Dasha29f 10 февр. 2022 г., 20:51:31 | 5 - 9 классы

Дано трехзначное число Х, вводимое с клавиатуры?

Дано трехзначное число Х, вводимое с клавиатуры.

Первую цифру этого числа перенесли в конец.

Вывести на экран полученное число.

( работать в паскале).

Настя3000111 11 янв. 2022 г., 09:28:04 | 10 - 11 классы

Даны два целых числа A и B ( A < B ) Найти частное, получаемое при делении A на все делители из диапазона целых чисел от A до B включительно?

Даны два целых числа A и B ( A < B ) Найти частное, получаемое при делении A на все делители из диапазона целых чисел от A до B включительно.

Это паскаль, только код напишите нормально, пожалуйста.

Заранее, спасибо.

АллаКолтуклу 8 апр. 2022 г., 07:55:56 | 5 - 9 классы

Дано 2 числа, вывести на экран целую часть их полусуммы?

Дано 2 числа, вывести на экран целую часть их полусуммы.

Dim250696 21 мар. 2022 г., 00:10:52 | 5 - 9 классы

Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа?

Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа.

Nokiashiniaev 17 февр. 2022 г., 15:58:07 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Ввести с клавиатуры 3 числа.

Вывести их на экран в порядке возрастания.

Помогите пожалуйста!

Daria3229 30 мар. 2022 г., 14:45:11 | студенческий

Помогите пожалуйста составить задачу на JAVA (Определить, является ли число а делителем числа b?

Помогите пожалуйста составить задачу на JAVA (Определить, является ли число а делителем числа b?

А наоборот?

(Получить два ответа.

).

Женя321 14 мар. 2022 г., 05:53:10 | 5 - 9 классы

Даны 2 числа А и В?

Даны 2 числа А и В.

Найти наибольшее и наименьшее из них и вывести на экран.

Паскаль.

Помогите пожалуйста.

Ayz12ktn 12 мар. 2022 г., 04:45:19 | 5 - 9 классы

Помогите найти количество нечетных делителей числа в паскале?

Помогите найти количество нечетных делителей числа в паскале.

На этой странице вы найдете ответ на вопрос Два множества : первое все простые делители некоторого целого числа N и второе все простые делители того же числа?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.