ПРОГРАМИРОВАННИЕ В ПАСКАЛЕ?

Информатика | 5 - 9 классы

ПРОГРАМИРОВАННИЕ В ПАСКАЛЕ.

Вводится двухзначное число.

Упорядочить цифры в нём по возрастанию.

Вывести результат на экран.

Пример Ввод : 64 Вывод : 46 Ввод : 23 Вывод : 23

P.

S. : Вводится одно число – N (от 10 до 99).

Выводится результат – новое число.

Дополнительных переменных нет!

Ответить на вопрос
Ответы (1)
Марина1910 24 сент. 2021 г., 15:48:57

Var

a, b, c : integer ;

begin

writeln('Vvedite chislo ot 10 do 99') ;

readln(c) ;

a : = c div 10 ;

b : = c mod 10 ;

if b>a then writeln(c) else

begin

c : = b * 10 + a ;

writeln(c) ;

end ;

end.

1242кпцпва 25 июн. 2021 г., 02:40:23 | 5 - 9 классы

Вводятся два целых числа?

Вводятся два целых числа.

Выведите YES, если их сумма делится на 3, NO в ином случае.

Ввод Вывод 1 2 YES Ввод Вывод 2 5 NO.

Dakuko 13 янв. 2021 г., 09:26:15 | 5 - 9 классы

Вводится число N?

Вводится число N.

Выведите те числа от 1 до N, которые делятся на 13.

ПРИМЕРЫ :

25 - ВВОД

13 - ВЫВОД

39 - ВВОД

13 26 39 - ВЫВОД

Pascal abc.

Blondinkasax 23 авг. 2021 г., 00:25:08 | 5 - 9 классы

Даны три числа?

Даны три числа.

Выведите медиану этого набора — второе по величине число.

На вход подаются 3 числа.

Ввод Вывод 1 2 3 2 Пример 2 Ввод Вывод 1 3 2 2 Пример 3 Ввод Вывод 2 1 3 2.

Valeroncykstoy 28 мар. 2021 г., 22:32:15 | 1 - 4 классы

Устройства ввода сообщений?

Устройства ввода сообщений.

Устройства вывода сообщений.

Устройства ввода и вывода сообщений.

Варвара98765432 28 янв. 2021 г., 11:35:48 | 5 - 9 классы

Выведите число, полученное при прочтении цифр данного числа справа налево?

Выведите число, полученное при прочтении цифр данного числа справа налево.

Вводится четырехзначное число.

Паскаль абс нет Пример 1 Ввод Вывод 1234 4321.

Klimkaklim 26 мар. 2021 г., 11:06:53 | 10 - 11 классы

Как осуществляется ввод и вывод данных в программу в Паскале?

Как осуществляется ввод и вывод данных в программу в Паскале?

Приведите пример.

Evdokimovvaler 20 июл. 2021 г., 16:23:21 | 5 - 9 классы

Вводятся два числа N и K?

Вводятся два числа N и K.

Выведите количество чисел из диапазона от 1 до N включительно таких, что их сумма цифр делится на K.

Пример ввода

100 3

Пример вывода

33

Пример ввода

22 4

Пример вывода

5

в программе Dev c + +.

НастикNike 8 окт. 2021 г., 00:46:35 | 5 - 9 классы

1. / Вводится любое число с клавиатуры?

1. / Вводится любое число с клавиатуры.

Если оно четное умножить его на 2, иначе прибавить 1.

Полученное число вывести на экран.

2. / На экране выводится сообщение «Сколько в 1 байте бит?

» Если вводится правильное число, то на экране выводится сообщение «Молодец!

», иначе – «Повтори единицы измерения количества информации».

ПАСКАЛЬ.

Madamgutickowa 29 нояб. 2021 г., 20:33:29 | 10 - 11 классы

10. Составить программу, осуществляющую ввод числовых переменных?

10. Составить программу, осуществляющую ввод числовых переменных.

При вводе положительного числа вывести информацию : «Число больше ноля», при вводе отрицательного числа – «Число меньше ноля», при вводе ноля – «Вы ввели ноль».

Annabaidinaaa 16 авг. 2021 г., 15:34:29 | 10 - 11 классы

Помогите с Паскалем?

Помогите с Паскалем!

С клавиатуры вводится четырехзначное натуральное число.

Поменяйте в нем местами первую цифру со второй и третью с четвертой.

Затем результат надо вывести на экран.

Оператор вывода в программе должен быть единственным и выглядеть так : writeln(y).

На странице вопроса ПРОГРАМИРОВАННИЕ В ПАСКАЛЕ? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.