Помогите с Паскалем?

Информатика | 10 - 11 классы

Помогите с Паскалем!

С клавиатуры вводится четырехзначное натуральное число.

Поменяйте в нем местами первую цифру со второй и третью с четвертой.

Затем результат надо вывести на экран.

Оператор вывода в программе должен быть единственным и выглядеть так : writeln(y).

Ответить на вопрос
Ответы (1)
Sergeykrav20 16 авг. 2021 г., 15:34:34

Var n, y : integer ; a, b, c, d : integer ;

Begin

readln(n) ;

a : = n div 1000 ;

b : = n div 100 - a * 10 ;

c : = n div 10 - a * 100 - b * 10 ;

d : = n mod 10 ;

y : = b * 1000 + a * 100 + d * 10 + c ;

writeln(y) ;

end.

Пример : 4295 (5290)

Вывод : 2459 (2509).

Kirilovich12 2 июн. 2021 г., 23:46:02 | 5 - 9 классы

Почему перед оператором ввода в программе Паскаля целесообразно записывать оператор вывода?

Почему перед оператором ввода в программе Паскаля целесообразно записывать оператор вывода?

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Помогите, пожалуйста, проболела эту тему : С.

DressT 28 июн. 2021 г., 00:33:58 | 5 - 9 классы

Написать программу в паскале : Вывести на экран натуральные чётные числа от 10 до 80(While)?

Написать программу в паскале : Вывести на экран натуральные чётные числа от 10 до 80(While).

Ryzhikhanna 9 авг. 2021 г., 15:34:56 | 5 - 9 классы

Составить программу, которая выводит на экран значение выражения 3 в ступени n - натуральное число, которое вводится с клавиатуры?

Составить программу, которая выводит на экран значение выражения 3 в ступени n - натуральное число, которое вводится с клавиатуры.

Vordemon 13 авг. 2021 г., 06:04:05 | 5 - 9 классы

Составить программу в паскале ABC для решения следующей задачи?

Составить программу в паскале ABC для решения следующей задачи.

С клавиатуры вводятся 3 произвольных числа.

Если второе число больше суммы первого и третьего , то вывести сумму этих двух чисел.

Если первое число положительное , то вывести среднее арифметическое трех чисел.

Ainura0009999999 9 июн. 2021 г., 12:33:30 | 10 - 11 классы

Вводится число с клавиатуры?

Вводится число с клавиатуры.

Необходимо вывести его на экран и выяснить четное оно или нет.

Напишите программу на языке JavaScript.

Ayqun023 10 авг. 2021 г., 20:20:15 | 10 - 11 классы

Задача : с клавиатуры вводится число от 1 до 1000?

Задача : с клавиатуры вводится число от 1 до 1000.

Программа должна вывести его прописью.

(Написать программу на Паскале).

Loshpe 2 янв. 2021 г., 13:00:58 | 10 - 11 классы

Составить программу, содержащую операторы ввода, вывода, присваивания?

Составить программу, содержащую операторы ввода, вывода, присваивания.

9)Найти произведение всех цифр заданного четырехзначного числа.

Anton99911 24 сент. 2021 г., 15:48:51 | 5 - 9 классы

ПРОГРАМИРОВАННИЕ В ПАСКАЛЕ?

ПРОГРАМИРОВАННИЕ В ПАСКАЛЕ.

Вводится двухзначное число.

Упорядочить цифры в нём по возрастанию.

Вывести результат на экран.

Пример Ввод : 64 Вывод : 46 Ввод : 23 Вывод : 23

P.

S. : Вводится одно число – N (от 10 до 99).

Выводится результат – новое число.

Дополнительных переменных нет!

KrytoichelovekGfgfh 18 июн. 2021 г., 01:28:41 | 10 - 11 классы

Помогите по ПаскалюС клавиатуры вводится вещественное число?

Помогите по Паскалю

С клавиатуры вводится вещественное число.

Вывести сумму трёх его первых цифр после десятичной точки.

Dubinina9818 29 дек. 2021 г., 15:17:33 | 5 - 9 классы

НА ПАСКАЛЕ С клавиатуры вводится вещественное число?

НА ПАСКАЛЕ С клавиатуры вводится вещественное число.

Вывести сумму

трёх его первых цифр после десятичной точки.

СРОЧНО, ПОЖАЛУЙСТА.

Вы перешли к вопросу Помогите с Паскалем?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.